Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair superflo shuts off after 30 seconds

  1. Back To Top    #1

    Join Date
    Jul 2015
    Location
    Miami, Fl
    Posts
    32

    Pentair superflo shuts off after 30 seconds

    Hello all. So I emptied my pool to have it replastered on Thursday. Once the water reached a certain level, I shut off pump and turned off breaker. Turned it back on, primed it and it began turning off after running for a couple of minutes. I have it fully primed now and it's now shutting off after 30 seconds, both on low and high. Pump is not hot to the touch. I left it off for 30 minutes, went back and same thing. What else can I check? Is the pump dead? Any info or help greatly appreciated. Thanks

  2. Back To Top    #2

    Join Date
    Apr 2016
    Location
    TX
    Posts
    51

    Re: Pentair superflo shuts off after 30 seconds

    The thermal overload circuitry might have been fried. Is it an old pump? Could be worn brushes, near the end of their life, etc. You might check to make sure all of the right voltages are present at the pump.

    Good luck!

    Take care,
    Mo
    Mo - 21K gal, IG plaster, dual Pentair SuperfloXF pumps, 72 sqft DE filter, cartridge filter for the spa, dual Waterco multi-cyclone prefilters, Dual Circupool SWGs, Polaris booster and cleaner, TBD custom controller.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •