Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 14 of 14

Thread: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

  1. Back To Top    #1

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Good afternoon everyone. I have a spa that waterfalls into my pool. The spa is heated by a Sta Rite SR200 Natural Gas Heater. Here's my problem though. When I activate the heater, the temperature on the heater reads about 30 degrees colder than the actual water temperature. The heater will still heat the pool, but since it thinks it's 30 degrees cooler than it actually is, the heater never turns off. It basically heats the water so hot that I have to manually turn it off and on to try and regulate the temperature. I've already replace the thermistor and high limit switch. The old thermistor looked ok, but I replaced it anyway. The high limit switch was broken. So anyway, both have been replaced, and I'm still having the same problem. Any idea what it could be? Any help is appreciated. Thanks so much.

  2. Back To Top    #2

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Any chance that it's set to metric?

    What temperature do you have the heater set to?

    What is the actual water temperature and what does the display show?

    Does the temperature displayed change as the water heats up?

    To toggle the display between degrees Centigrade (C) and degrees
    Fahrenheit (F):
    1. Turn the Operating Control OFF.
    2. Press ▲ TEMP or ▼ TEMP for 5 seconds. The display will flash
    once and change modes (C to F or vice versa).
    3. Turn the Operating Control ON.

    Usually it's going to be a bad thermistor. Since you replaced the thermistor, I would suspect that the control board might be bad.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  3. Back To Top    #3

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    I went out and checked just now. It's set on Fahrenheit. However, I toggled it over to Celsius and then powered the heater on. I then powered it off and then switched it back to Fahrenheit. I'm happy to report that it's now reading the temperature correctly! I measured the water temperature at 65.6 degrees. The heater is registering at 66 degrees. Pretty close if you ask me. When i first checked, it was registering the water temp as 34 degrees. It's almost like it just refreshed or something. Like a computer would when you reboot it. Strange. Either way, thanks so much! I didn't even know that you could toggle back and forth between Celsius and Fahrenheit. Thank you thank you. I will continue to check it over the weekend and report back.

  4. Back To Top    #4

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Good job. Thanks for the update.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  5. Back To Top    #5

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    One more update. Just used the spa this evening. Temperature was reading perfectly and the heater was functioning exactly the way it should. It was nice not having to get in and out of the spa to keep turning the heater on and off. Thanks again.

  6. Back To Top    #6

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Thanks for the update.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  7. Back To Top    #7

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    I'm back again. Fired up the heater yesterday. Temperature is back to reading about 30 degrees lower than the actual water temperature. I tried what we did last night when we toggled back and forth between Celsius and Fahrenheit. No luck. Kept reading 30ish degrees colder than the water actually is.
    AKA Bill 9300 Gallon Plaster In Ground. Some sort of pump. Sta-Rite Max E Therm 200 Natural Gas Spa Heater. Hayward Pool Vac. PXC-75 cartridge filter Taylor K-2006 Test Kit. Probably some other stuff that I don't even know about. Just learning. :-)

  8. Back To Top    #8

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Probably going to need a new temperature sensor.

    Check all wiring. It might be a bad connection.

    If the thermistor is new, I would suspect that the board is bad.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  9. Back To Top    #9

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Quote Originally Posted by JamesW View Post
    Probably going to need a new temperature sensor.

    Check all wiring. It might be a bad connection.

    If the thermistor is new, I would suspect that the board is bad.

    Yep. Already did a new thermistor. Was hoping it wasn't the board. A bad board could cause an inaccurate temp reading?
    AKA Bill 9300 Gallon Plaster In Ground. Some sort of pump. Sta-Rite Max E Therm 200 Natural Gas Spa Heater. Hayward Pool Vac. PXC-75 cartridge filter Taylor K-2006 Test Kit. Probably some other stuff that I don't even know about. Just learning. :-)

  10. Back To Top    #10

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    I suspect that it's a bad board.

    If the wiring is good, I would replace the control board.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  11. Back To Top    #11

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Quote Originally Posted by JamesW View Post
    I suspect that it's a bad board.

    If the wiring is good, I would replace the control board.

    Thanks for the info. I guess that's next on the list.
    AKA Bill 9300 Gallon Plaster In Ground. Some sort of pump. Sta-Rite Max E Therm 200 Natural Gas Spa Heater. Hayward Pool Vac. PXC-75 cartridge filter Taylor K-2006 Test Kit. Probably some other stuff that I don't even know about. Just learning. :-)

  12. Back To Top    #12

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    I think that the thermistor is 10k. Check the resistance against a 10k thermistor chart.

    Also, you could connect a 10k resistor to the the thermistor connection in place of the thermistor as a diagnostic only. If it reads 77 f, the board is likely good. If it reads low, the board is probably bad.

    At 10k ohms, the temperature readout should be 77 Fahrenheit. Radio shack should have the resistor.

    Note: I'm pretty sure that it's a 10k thermistor.
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  13. Back To Top    #13

    Join Date
    Jun 2017
    Location
    New York,USA
    Posts
    1

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Hi...i am a new user here. I had the same issue and i toggled it over to Celsius and then powered the heater on. I then powered it off and then switched it back to Fahrenheit. I measured the water temperature at 65.6 degrees. The heater is registering at 66 degrees. When i first checked, it was registering the water temp as 34 degrees. It's almost like it just refreshed or something.

    circuit assembly

  14. Back To Top    #14

    Join Date
    Mar 2017
    Location
    Saint Petersburg, FL
    Posts
    89

    Re: Sta Rite SR200NA Heater - Temperature Not Reading Correctly

    Quote Originally Posted by LulaNord View Post
    Hi...i am a new user here. I had the same issue and i toggled it over to Celsius and then powered the heater on. I then powered it off and then switched it back to Fahrenheit. I measured the water temperature at 65.6 degrees. The heater is registering at 66 degrees. When i first checked, it was registering the water temp as 34 degrees. It's almost like it just refreshed or something.
    Yep. That's exactly what happened to me. Weird. That being said, I had it happen again a couple of months ago. This time, that DID NOT fix the problem. I didn't have time to mess with it at that time, so I just left it alone. I checked it again about 2 weeks ago, and everything was working as it should.
    AKA Bill 9300 Gallon Plaster In Ground. Some sort of pump. Sta-Rite Max E Therm 200 Natural Gas Spa Heater. Hayward Pool Vac. PXC-75 cartridge filter Taylor K-2006 Test Kit. Probably some other stuff that I don't even know about. Just learning. :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •