Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Multi Port Valve Leaking Sporadically

  1. Back To Top    #1
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    172

    Multi Port Valve Leaking Sporadically

    I've noticed that sometimes my multi port valve leaks. The other day I noticed it leaking profusely out from under the handle. I stopped everything, changed the handle setting around a little, put it back on filter and turned it back on...no leak. Some quick googling tells me the spider gasket is the likely culprit and it needs to be greased or replaced. Does this sound right?

    Another piece of info is that the spring on the handle always seemed loose (I've only owned this pool since last July). It kinda sits in a flimsy, half cocked position when it is not depressed. Is this the way it's supposed to be? Should it sit up where it's flush with the top of the value when not being depressed?

    Does anyone have any advice? Tips or tricks on how I don't tear up my valve in the process?

    I don't have a picture or part number because I'm not at home, but I believe mine is similar to this:

    Pentair HiFlow Multiport Valve 261050. Pentair 261142.
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  2. Back To Top    #2
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    8,546

    Re: Multi Port Valve Leaking Sporadically

    Yeah, it does sound like your spider gasket has gone kaput! I understand it is a fairly straightforward and not too difficult a task to change. Youtube has some videos on this, I seem to recall?

    One thing I learned is to only turn the handle in one direction only.. either clockwise or counterclockwise, but not back and forth. That back and forth stuff can cause the gasket to shred a bit.

    Sorry I have no ideas on the spring handle issue. I hope someone else comes along with an answer.

    Yippee
    Maddie :) 12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Skippy's Pool Cooler --> Skippy's New Fountain Our Build --> Our Pool Solved Our Sloping Yard

  3. Back To Top    #3

    Join Date
    Nov 2014
    Location
    United Kingdom
    Posts
    226

    Re: Multi Port Valve Leaking Sporadically

    The spider gasket is the likely culprit
    It's an easy job to replace
    Not sure about the spring but if it doesn't leak it should be okay
    BTW don't move the handle with the pump running


    10,000 gallons inground Leisure fibreglass pool, Hayward powerline pump, Quality120 glass media filter, 27kw output air source heat pump and thermal cover.
    Retractable cover with Polycarbonate roof and glass side for all year round use. K-2006C test kit and Speed stir

  4. Back To Top    #4
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    172

    Re: Multi Port Valve Leaking Sporadically

    Quote Originally Posted by denniswiseman View Post
    btw don't move the handle with the pump running
    sent from my iphone using tapatalk
    never!

    - - - Updated - - -

    Thanks, I'll hit up youtube, I was just making sure it was a DIY kinda thing. The multi port valve is something I haven't had to crack open yet...

    This pool stuff is pretty easy as long as you become a plumber and a mechanic
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  5. Back To Top    #5

    Join Date
    May 2011
    Location
    lebanon tn
    Posts
    370

    Re: Multi Port Valve Leaking Sporadically

    The handle spring really only helps lock valve in position. Shouldn't be an issue as long as no kids play with it
    24ft x 52in AGP 18000 gal
    sand filter, 200#,1.5 hp single speed pump
    Wood deck (still in progress...)

  6. Back To Top    #6

    Join Date
    Jul 2012
    Location
    Dallas, TX
    Posts
    179

    Re: Multi Port Valve Leaking Sporadically

    Bigdog43

    I have a different model Pentair Multiport Valve 261152 but looking at a couple of sites regarding your model valve, the basic parts schematic is similar to my valve.

    The source of my handle leak was my Top Valve Cover. The O-ring sealing inner circumference surface was allowing water to leak by the Diffuser Shaft O-rings on my Diffuser Stem.

    The part number for your valve would appear to be Pentair 272412 .

    I had a valve leak that appears similar to your issue so these threads may help provide some information:

    Pentair Multi-port leak

    Pentair Multiport Problems

    You may want to consider purchasing a spare Top Assembly Pentair 272422 to have on hand whenever the Top Assembly needs servicing. I have a spare one for my valve so I can swap it out and rebuild the original assembly to keep it ready for a fast swap spare.
    - Pool Type: 15k Gal Gunite IG non-SWG / Built 1988
    - Pump: Pentair Challenger / Sweep Pump: Letro Model LA01N .75HP Single-speed / 6 hrs-day (1 turnover)
    - D.E. Filter: OEM: Nautilus (Pentair) #NS 36 / 36 Sq Ft / D.E. Charge: 3.6 Lb
    - Pentair 4-wheel Sweep LL505G - Booster Pump runs ~2 hrs/day

  7. Back To Top    #7
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    172

    Re: Multi Port Valve Leaking Sporadically

    Actually my part number is 261050, the one in the original post was just an example that looked like mine. I should've looked at mine before posting. The top assembly also has a number on it, 27-2101.

    If I wanted to replace the whole top assembly, is this what I need?

    https://www.amazon.com/Pentair-27242...261050+pentair
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

  8. Back To Top    #8

    Join Date
    Jul 2012
    Location
    Dallas, TX
    Posts
    179

    Re: Multi Port Valve Leaking Sporadically

    The Amazon link part should be the correct Top Assembly for your valve. The Part # 27-2101 appears to be the template valve label for the valve (indicating the valve positions, Filter, Rinse, etc).
    - Pool Type: 15k Gal Gunite IG non-SWG / Built 1988
    - Pump: Pentair Challenger / Sweep Pump: Letro Model LA01N .75HP Single-speed / 6 hrs-day (1 turnover)
    - D.E. Filter: OEM: Nautilus (Pentair) #NS 36 / 36 Sq Ft / D.E. Charge: 3.6 Lb
    - Pentair 4-wheel Sweep LL505G - Booster Pump runs ~2 hrs/day

  9. Back To Top    #9
    JRRandall's Avatar
    Join Date
    Jul 2016
    Location
    Norwood, MA
    Posts
    1

    Re: Multi Port Valve Leaking Sporadically

    Quote Originally Posted by Bigdog43 View Post
    Actually my part number is 261050, the one in the original post was just an example that looked like mine. I should've looked at mine before posting. The top assembly also has a number on it, 27-2101.

    If I wanted to replace the whole top assembly, is this what I need?

    https://www.amazon.com/Pentair-27242...261050+pentair
    Sorry for posting to a slightly old thread, but I have the exact same multi port valve about 8 years old and I have the exact same small leak coming out of the top assembly where the valve stem is located. I don't have even a drop coming out the backwash/waste port so I doubt my problem is the spider gasket? I was just wondering if you were able to fix the problem with just the top cover or did you go with the whole top assembly? Also, if you did go with just the top cover what did you do about the multi port label? It doesn't appear to me by looking at pictures of Pentair-272412 that it comes with any sort of label. Any advice is appreciated, especially from someone who's experienced the same symptoms!

  10. Back To Top    #10
    Bigdog43's Avatar
    Join Date
    Jul 2016
    Location
    Memphis, TN
    Posts
    172

    Re: Multi Port Valve Leaking Sporadically

    Sorry for the late response. I replaced the top assembly and the spider gasket. I may have been able to get away with just the gasket. Stopped the leak...
    Memphis, TN.
    Pool IG, 20K gallon, Gunite. Triton Sand filter, Pentair Pump, Polaris 280, Doheny Discovery Dolphin, Chlorinating Liquid, Rock Water Feature, New Plaster 2015
    Spa 450 gal, Tropic Seas Waikiki 864L, Bromine
    Taylor K-2006

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •