Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Filter doesn't seem to be doing its job

  1. Back To Top    #1

    Join Date
    Jul 2016
    Location
    Oakdale,CA
    Posts
    4

    Filter doesn't seem to be doing its job

    I noticed a lot of sand in my pool this weekend. The sand is from a dry well that is suppose to serve as an overflow for the autocover housing. I never ran drainage for the dry well so the rain is going through the dry well and draining into my pool. This is also bring sand into my pool as i have not put in landscaping yet. I just got through the rainy season so I am trying to clean my pool water. I ran the pump all day Saturday and Sunday but the water seems to be getting worse in clarity and looks dirtier (if that is possible). Before I cleaned the cartridge filters before I started the filter on Saturday. The filter has been running at about 15 psi. I am a new pool owner and pretty sure something is wrong but don't know where to start. I am using a Zodiac MX8 to vacuum my pool. I actually took it to Leslies pool to make sure it wasn't broken. It is fine and in good working order. Please help!
    In ground 20x36, 27K gallons, Jandy equipment, CV460 cartridge filter, 400K BTU Heater, UV/Ozone cleaner, PebbleFina.

  2. Back To Top    #2
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    9,304

    Re: Filter doesn't seem to be doing its job

    napro,

    Welcome to TFP.. A Great resource for all your pool questions...

    Water clarity issue can be many things, so the very first thing everyone here will want to know is what are your testing results..

    FC
    CC
    pH
    TA
    CH
    CYA

    Let us know and we'll see what we can do to help.

    Thanks for posting,

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Caldera Spa.

  3. Back To Top    #3

    Join Date
    Jul 2016
    Location
    Oakdale,CA
    Posts
    4

    Re: Filter doesn't seem to be doing its job

    Thank you for your help. These are the results

    Free Chlorine: 2 ppm
    Total Chlorine: 2 ppm
    Calcium Hardness: 120 ppm
    CYA: 10 ppm
    Total Alkalinity: 90 ppm
    pH: 7.8

    I also bought Clear aid from Leslie pools. I didn't want to but I was desperate. I just put it in and no visible change but the bottle did warn that if the pool temp was below 70, it would take more time than usual.

    Any thoughts
    In ground 20x36, 27K gallons, Jandy equipment, CV460 cartridge filter, 400K BTU Heater, UV/Ozone cleaner, PebbleFina.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •