Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: did I damage the cell?

  1. Back To Top    #1

    did I damage the cell?

    I have a zodiac swg with the nature 2 duo clear system. It was on the whole time I was balancing the water. I hit the off button on the control panel but some how it went on,at some point. Is the cell now damaged?

    The salt level was at around 2100 ppm. The add salt light was on but I read it could be lit because of water temp. My next question is, do I have to replace the duo clear cartridge since it ran with all the algae in the pool? Unfortunely the pump can not run without the cartridge in because there would be a void,the cover is basically a screw on ring.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: did I damage the cell?

    It is very unlikely that anything will have been damaged. If you have a bottom drain and a whole bunch of salt got into the drain you could possibly have overloaded the power supply, but if it shows any sign of life at all now that the salt addition is over it should be completely fine.

    There isn't any need to change the cartridge. Algae won't bother the cartridge.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

  4. Back To Top    #4

    Re: did I damage the cell?

    Thanks for your reply, it cost about $800.00 to replace.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  5. Back To Top    #5

    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    874

    Re: did I damage the cell?

    just re-read your initial question again and want to clear up something.
    are you asking whether you damaged the cell, the cartridge or both?

  6. Back To Top    #6

    Re: did I damage the cell?

    Is it safe to assume the cartridge needs to b replaced?
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  7. Back To Top    #7

    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    874

    Re: did I damage the cell?

    i would suggest not replacing it in any case, as it's pretty much useless anyway

  8. Back To Top    #8

    Re: did I damage the cell?

    Why do you say its useless?
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  9. Back To Top    #9

    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    874

    Re: did I damage the cell?

    because it doesn't do much to warrant the purchase of a new cartridge

    have a read through this thread

    nature-2-and-bleach-t1749.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •