Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Good Morning. I need help w/filter problem

  1. Back To Top    #1

    Good Morning. I need help w/filter problem

    Hi,
    I just registered on this site. I actually registered b/c I wanted help w/a problem and hoped someone could help me! We have an above ground 24 foot round pool. We have had it for around 5 years. This year, whenever we turn off the pump, water blows out of the skimmer. It has never done this before. I am also noticing air under the clear lid of the pump when we turn it on. Any idea where this air is coming from, and if it is the reason we are getting water blown at us every time we turn off the pump? My hubby does not think the excess air is a big deal, and isn't worried about it. However, I am concerned that it may be damaging our pump. Any help would be greatly appreciated!
    Thanks!
    Tammy
    13 K gal 24 Octagon (yeah, really) vinyl.
    Proline DE filter, 3/4 hp Hayward pump, inline chlorinator, Jandy Lite2 propane heater

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,617

    Re: Good Morning. I need help w/filter problem

    Welcome to TFP.

    Yes, the air is the reason for the skimmer problems. Try the simple things first. Inspect and possibly replace the O-rings on the pump strainer basket lid and the pump drain plugs. Make sure all of those O-rings are lubed with pool lube and then make sure they are tight.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3
    frustratedpoolmom's Avatar
    Join Date
    May 2007
    Location
    SWSuburban Chicago, IL
    Posts
    11,963

    Re: Good Morning. I need help w/filter problem

    Hi there. Welcome!

    Can you give us some more info? Put all your specs/equipment in your Sig. Go to User Control Panel, top left, then Profile, then Edit Signature.

    Model/ type of pump and filter, etc, see my sig for an example.

    It sounds like you have a suction side air leak. You need to check all connections, clamps, drain plugs leading to the pump from the skimmer, and tighten any loose clamps/connections. Check the drain plug at the bottom of the pump basket. Sometimes too the seals on the pump basket lid goes bad and that can allow air in.... make sure all the air is bled out of the top of the filter, there is an air release valve on the top usually, you want to open that and allow the air to escape and then tighten it back down.
    Helpful links: Pool School; CYA/Chlorine Chart
    24' round AG pool, 52" high, Raypak heater; Waterway 2 spd Pump;
    150 Sq ft. Clearwater Cartridge Filter; Former and DISSATISFIED "Pool Frog" owner
    http://www.PerfectlyClearPoolService.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •