Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Filter pressure dropping and holding?

  1. Back To Top    #1

    Filter pressure dropping and holding?

    I recently installed a Hayward t180 filter and 1Hp hayward power max pump. Filter has 200lbs Zeobrite. Anyways, after doing the spring cleaning the pressure was hodling at roughly 19 psi. I have backwashed a few times, as I had an algae bloom and other issues getting the pool opened. I backwashed it today after vacuuming some funky stuff after a storm and the pressure dropped to 12, and is holding at 12 psi. Bad gauge? Something "stuck" that finally came out? I have not a clue, but my suction is better than it has EVER been. I have had Leslies( where I bought the pump/filter) out 3 times before for suction loss, and they found nothing wrong......suddenly with lower psi it is great....any hints? Comments?
    Hurricane Rita did not kill me, but she killed my pool!


    Intex 36'X18'x52" "elliptical pool"/ Hayward 220 filter/1HP pump 14,364 gal, or so

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887
    My guess is something stuck in the return pipe that finally came out.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •