Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: My Hayward Pool Vac Ultra only turns left

  1. Back To Top    #1

    My Hayward Pool Vac Ultra only turns left

    I have a Hayward Pool Vac Ultra, which has been in use for the past 4 years, now entering our fifth swim season. I live in Southern California, so this vac has been in use for at least 5 hours a day for over 4 years. It's been a GREAT vacuum for nearly all of this time.

    Recently, I noticed that it will only make left hand turns, and therefore, the hose gets pretty coiled up, and it has trouble covering the whole pool, especially the area to the right of the vacuum inlet port in the pool wall. I have ordered the maintenance kit, which includes the wings, flaps and feet, but it seems like something more serious may be involved. The vac is cleaned, no debris inside, etc. Has anyone else had this problem, and could diagnose the problem? Is there a replacement part that controls the steering? The Hayward literature states that the vac is supposed to make alternating left and right turns.

    thanks
    15,000 gallon IG pebble pool/spa | Pentair 400k BTU heater | Pentair cartridge filter | Goldline AquaRite SWG T-Cell-15
    Pentair IntelliFlo Variable Speed Pump | 3 Pentair Whisperflo pumps (1-2 HP) | Hayward Aquabot | Pentair Intellitouch controls

  2. Back To Top    #2
    Molson's Avatar
    Join Date
    Apr 2008
    Location
    Midland, Ontario
    Posts
    479

    Re: My Hayward Pool Vac Ultra only turns left

    Did you let it sit and watch Nascar in the off season??

    I'm sure something is bound up in the works, and someone with a similar unit will pipe up here shortly.
    40 x 16 IG Vinyl. Goldline SWG
    160 Sq Ft Roof mounted solar array
    2014 Hydropool Serenity 5000 Hot Tub
    The Pool School- A great place to start
    Jason's Pool calculator

  3. Back To Top    #3

    Re: My Hayward Pool Vac Ultra only turns left

    Anyone have any thoughts?
    15,000 gallon IG pebble pool/spa | Pentair 400k BTU heater | Pentair cartridge filter | Goldline AquaRite SWG T-Cell-15
    Pentair IntelliFlo Variable Speed Pump | 3 Pentair Whisperflo pumps (1-2 HP) | Hayward Aquabot | Pentair Intellitouch controls

  4. Back To Top    #4
    ultra800_96's Avatar
    Join Date
    May 2009
    Location
    Pomeroy, Iowa
    Posts
    225

    Re: My Hayward Pool Vac Ultra only turns left

    I have the Hayward Aquabug, & it is similar in that it makes 3 right turns, goes straight for about 10 feet, then makes 3 left turns, etc. Mine was doing the same exact thing. From outward appearances it looked clean. I took it apart down to the little gears that do the steering, & I had a pine needle jammed in between a couple of the teeth of the little gears. removed that, & now all is well. Hope that helps. You may have a stripped gear also. That would do the same thing.
    12,900 Gal. 24' X 48" ABG Vinyl Round (17th Birthday)
    1HP Hayward Pump w/S180T Hayward Sand Filter
    AquaTrol RJ SWCG 2011 startup
    TFP Method since '09, TF100
    50ppm Borates, June '12

  5. Back To Top    #5

    Re: My Hayward Pool Vac Ultra only turns left

    Ultra--

    Thanks for the advice. I went ahead and opened mine up. It's much simpler than I thought it would be. Only a total of 10 or so screws. All of the gears seemed to be in good working order, and I didn't notice any debris. I put it all back together, and guess what? It works fine now!! Maybe only temporarily, but we'll see. If not, I'll just replace the gears. I don't think they're too expensive on ebay, and it will be a simple fix.
    15,000 gallon IG pebble pool/spa | Pentair 400k BTU heater | Pentair cartridge filter | Goldline AquaRite SWG T-Cell-15
    Pentair IntelliFlo Variable Speed Pump | 3 Pentair Whisperflo pumps (1-2 HP) | Hayward Aquabot | Pentair Intellitouch controls

  6. Back To Top    #6

    Join Date
    May 2014
    Location
    Sparta N.J.
    Posts
    4

    Re: My Hayward Pool Vac Ultra only turns left

    I have the same problem with my Pool Vac XL. Goes only left! Had it totally apart but can't find anything stuck or wrong! I also have one from 1980 that I'm using while the new one is figured out. Any help would be great! Thanks Ron

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •