Search results

  1. 2

    Doheny's Discovery, S200, Active20, Triton owners club

    Sorry for late reply, wasn't monitoring forum. I got through quickly both times - when I placed the order, and when I had to call 30 minutes after launch because the unit wasn't working properly - see my recent post here: active 20 problem, already On my problem call, Margaret had a tech call...
  2. 2

    active 20 problem, already

    Similar problem - Received my Active 20 last week - excited to try it. Placed in pool, ran about 15 minutes then just stopped. Remote light still on. Basically a Non-Active 20 (didn't even get to 20). Immediately called Marina Pool where I bought it. They asked if pool very dirty (actually was...
  3. 2

    Doheny's Discovery, S200, Active20, Triton owners club

    After sifting (no pun intended) through these pool cleaner discussions, I just placed an order with Marina for the Active 20. I appreciate the thorough reviews and comparisons. I am concerned with the few posts about decreased run times or failing motors though - have had my suction Nautilus...
  4. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    So I went ahead and purchased the Hayward T-Cell-940 (40K gal) at my local Pinch-A-Penny last weekend. First off, it's working too well, I overdid it and my first reading went from 0 to 8 ppm after a few days, so I turned down the %. It was the $599 list price with a $50 rebate. It was buy then...
  5. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    So, I also need to purchase a new cell. If it helps, here's my history on the compupool cell. I purchased the T13 for $359 July 23, 2012. Worked from the start, then stopped producing. I did their warranty exchange and submitted it 4/17/13 - had to give diagnostic readings, copies of receipt...
  6. 2

    Pool Math........The App

    Cannot login too.
  7. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    okay, so here's my 3 month update on the generic cell. Turns out the cell was fine, did the circuit board surgery, details here: post446419.html#p446419 Seems to be working fine now. So I have no issues with the compupool replacement, other than contacting customer support - they have never...
  8. 2

    Aquarite Not generating - lights not on

    Just did the same repair as described by many - first solder (and desolder) job for me too. For me it started late July when my T-15 cell went bad. Researched and purchased the compupool generic, taking a chance. http://www.titaniumcells.com/t-cell-15.html I also purchased the current...
  9. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    I received mytitanium cell from poolexpress and installed around end of July - worked right away, I had been adding liquid chlorine until then. Until recently, all was fine. Now not generating - flow is fine, realized it when green algae appeared. Called Friday (yesterday) tech support of...
  10. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    I just ordered one too. He told me it is the CompuPool (looks same in pictures) but is made especially for them. When I did check with other pool supply companies online, Poll Express seems to be the only one with the non-prorated warranty, as you indicated. Should have it by Thursday here in...
  11. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    kwuf, Wow - good find - reviews sound very convincing. I was considering the poolguysupply aftermarket, but there was no answer by phone Sat or Sun - was planning on trying again today. Now I think these titanium cells sound more promising - always more interested in the long term reviews of...
  12. 2

    need advice on replacement for SWG - Hayward T-CELL 15

    I also need to replace my t-15 after exactly 4 yrs use in FL. Did diagnostics with Hayward by phone today. Tested my pool water at 2 different pool stores today (not chains). One told me low salt (2500), other said 3200. Chlorine (i added liquid) and ph the same. Stabilizer readings different...