Search results

  1. S

    Rainbow 320 - Slow Dissolve

    I guess I'll have to increase the high speed pump time. My pump is only two speeds. Th weird thing is it used to dissolve tabs much faster and maintain higher chlorine levels. I realize my CYA is now in the 45-50 range as opposed to the high 80's + so the UV is eating much more chlorine now...
  2. S

    Rainbow 320 - Slow Dissolve

    I've been working this issue for a couple of weeks. The 3 inch tabs are dissolving very slowly. I've replaced the check valve, o-rings, back-washed the filter, etc. I also inspected the canister screen/filter at the bottom of the canister. It's not clogged. The pump runs on high speed from...
  3. S

    Urgent Next steps??

    I should've included my filter and cleaner run time schedule. It's attached
  4. Schedule.jpg

    Schedule.jpg

  5. S

    Urgent Next steps??

    Here are my current levels using my TFT test kit FAC - 3 CH - 175 TA - 100 PH - 7.8 CYA - 25 to 30 CSI - 0.13 (according to Pool Math app) OCLT - 3.5 to 3 (tested last night with pump that ran on low speed for 4 hours, no chlorine added overnight) Recent steps over the last two weeks...
  6. S

    Rainbow 320 Chlorinator troubleshooting

    My pump is running at full speed in the morning for three hours and again in the evening for three hours. It runs an additional 6 hours overnight at low speed. The incoming tube is connected to the upper port. Thanks for the suggestion!
  7. S

    Rainbow 320 Chlorinator troubleshooting

    I searched for answers but I’ve haven’t found any hence this post. My tabs aren’t dissolving/melting. Here are the steps I’ve taken/confirmed so far: Backwashed filter confirmed water is flowing into the canister by removing the lid and watching the water flow, solid flow removed screen from...
  8. S

    Manifold stuck in filter - Help!

    The wood-tap trick didn't work but it did move enough so i could remove a few of the grids. I sprayed WD40 between the manifold and pipe. Because half of the grids were out, I could rotate on the pipe about 30 degrees both counter and counter clockwise. That broke the seal on the o-ring and i...
  9. S

    Manifold stuck in filter - Help!

    going to try that now!
  10. S

    Manifold stuck in filter - Help!

    I'm attempting a thourough cleaning of my Jandy filter. I cant remove the grid to directly clean the grids. As you can see from the picture the manifold is stuck on the outlet pipe. I've tried wriggling and twisting gently the manifold. I'm using the built-in handles on the manifold to lift...
  11. Filter Manifold.jpg

    Filter Manifold.jpg

  12. S

    CYA Drain & Refill Guidance

    thanks for the guidance team. I use the TF Test kit. I took it to Leslie's to get a second measure on my CYA. My local store uses the automated test. My test and their test were really close. Even the guy in the store admitted its not more accurate than the Taylor kits but it's more...
  13. S

    CYA Drain & Refill Guidance

    Merged threads - TFP Mod I have a couple of issues and I'm not certain how I should go about fixing them. I'm fighting yellow algae and my CYA is 140. I know I have to drain and refill the pool to get the CYA down. I wont be able to get to it until Saturday. I have my chlorinator on the...
  14. S

    CYA Drain & Refill Guidance

    I'm reading the article now!
  15. S

    CYA Drain & Refill Guidance

    Great tips as always! I haven't tested my fill water but I will this evening. As you can see from the picture below, my pool has a drain pipe that goes directly to a sewer line. Do I still need to rent a pump or should I usethe backwash valve on my filter to direct the water to the sewer?
  16. IMG_8712.jpg

    IMG_8712.jpg

  17. S

    CYA Drain & Refill Guidance

    Using a TF-100, I get the following results: FAC 9.5, CH 325, TA 100, CYA 150, PH 7.5. Obviously, my CYA is really high. I used the pool math calculator and it said i should drain 75% and refill to bring CYA down to 40. My pool is 22K gallons and I live in Dallas, TX. Questions: Does...
  18. Spa.jpg

    Spa.jpg

  19. S

    Pump Functionality Question

    makes sense...thanks Jim!
  20. S

    Pump Functionality Question

    Please see the picture. Why is there a hose bib on the outlet pipe of my pump? I've had the pool for a couple of years and I've never used it. The only thing I could think of was a way to prime the pump?
  21. Jandy Pump.jpg

    Jandy Pump.jpg

  22. S

    Polaris 280 cleaner not moving

    Thanks!
  23. S

    Polaris 280 cleaner not moving

    here's the culprit! The impeller is broken where it connects to the shaft. Should i replace anything else while I'm replacing the impeller?
  24. Polaris Booster Pump-4.jpg

    Polaris Booster Pump-4.jpg

  25. S

    Polaris 280 cleaner not moving

    got it. I'll try it. thx
  26. S

    Polaris 280 cleaner not moving

    an update...I was able to remove the cap on the rear of the motor and freely turn the shaft by hand. I powered on the pump and the shaft is spinning. there is a really small leak at the front bottom of the pump. Does that mean I have a seal problem? How can I test the impeller? Thanks
  27. Polaris Booster Pump-2.jpg

    Polaris Booster Pump-2.jpg

  28. Polaris Booster Pump-3.jpg

    Polaris Booster Pump-3.jpg

  29. Polaris Booster Pump.jpg

    Polaris Booster Pump.jpg