Search results

  1. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    So bottom hole to pump, there’s a hole in the rear which is hard to see which is plugged and a hole in the front which connects to main drains.
  2. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    Pretty sure it’s not flex pvc. My fear is a collapsed pipe...my water level doesn’t seem to drop though. Been trying to avoid having someone come out because I’m cheap and stubborn lol. I tried to find a picture of the skimmer I have but can’t find one. Seems I have an awkward skimmer to...
  3. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    I can’t select between main drain or skimmer. The main drain has suction via the front port in the skimmer basket. Lemme see if I can post the skimmer I have or a pic.
  4. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    Video of my pump. When I first turn it on after filling it up with water to prime it (there’s a small leak with the heater because of rusted connection on heater...may replace or just remove) it runs well for 5-1 seconds then psi drops to 0 and it looks like the video.
  5. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    Just researched on a check valve and I don’t have anything like that above ground. Would doubt it would be plumbed under. So when I bought the house the pool was basically a swamp. The main drains were 100% clogged which I found out today. This leads me to believe there is a clog of sorts in...
  6. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    Yeah it’s plumbed like a pool. I didn’t think about a one way check valve....I’ve used the drain kings previously and was able to get water coming out of the pump when placed in skimmer line but when placed in the pump I wasn’t able to get water to come out of the skimmer. Essentially the...
  7. S

    Drained in ground spa to troubleshoot dismal suction. Please help.

    So as title says I drained my 5kish gallon spa because my system was running at 0 psi. Pump would start strong when I turn it on and run around 15 psi and within 5 seconds drop to 0 psi. I don’t think it was sucking in air....when I opened the pump lid it had a strong suction sound and feeling...
  8. S

    New pool owner - Pump loses prime and <1 psi

    It’s not too far. I bought a camera but i guess it’s not firm enough so it won’t fet through the bends lol. I also bought an auger but it also has troubles getting through. Perhaps I need higher quality stuff. Also——-at any time I can let air out of my filter for 2-3 seconds before water...
  9. S

    New pool owner - Pump loses prime and <1 psi

    sure did. Cleaned it again too. I’m pretty sure there is a clog in my skimmer line. When I put my hand into the hole I felt nothing. After some attempts trying to clear I felt some suction but not nearly enough. I tried covering the line with a ball and I killed the suction so I think...
  10. S

    New pool owner - Pump loses prime and <1 psi

    It’s a Hayward cartridge filter. I’ve cleaned it multiple times....I’ve done more testing and it appears I still have a clog in the skimmer line. Trying to flush it with a bladder and turning pump on and off to no avail ?
  11. S

    New pool owner - Pump loses prime and <1 psi

    Now it also runs through a heater after the filter which the heater has a very small drip which could be the sole reason I’m losing prime but as I understand it wouldn’t affect the poor pump suction...correct? I’ve thought about re-touting the lone to bypass the heater until I want to replace...
  12. S

    New pool owner - Pump loses prime and <1 psi

    its a cartridge filter. I’ve cleaned it twice in the past 2 months. It was pretty dirty when I bought the house so I cleaned it with a pressure washer. I bought some spray and cleaned it again a month ago and didn’t see any change. Could the filter be causing issues with the amount of water...
  13. S

    New pool owner - Pump loses prime and <1 psi

    https://www.youtube.com/watch?v=a4i4rkzcW6w&feature=youtu.be
  14. S

    New pool owner - Pump loses prime and <1 psi

    So there’s a pic of the bottom drains. To me they look dirty and possibly clogged. I never see any suction out of them. Would that cause issues with the pump suction and or losing prime? Posting a vid of my pump in action now too.
  15. S

    New pool owner - Pump loses prime and <1 psi

    So I also installed new pvc pipe since i made some cuts to help clear the pipe. Now I didn’t use pvc cement on part of it so I assume it would be leaking there....I used the larger pvc coupler but plan on sealing it in a few days....I wanted to test it all before i did something semi-permanent.
  16. S

    New pool owner - Pump loses prime and <1 psi

    It looks nothing like the other pumps I’ve seen in videos. I guess you could say it’s about half air.....I’ll fill the pump up with water until it’s completely full (fills pipe too) and put cover on. It will look like a normal pump should for a few seconds and hit 10 psi then It slows down and...
  17. S

    New pool owner - Pump loses prime and <1 psi

    Bringing this back from the dead now...I flushed the pipes best I could. Still can’t tell if it’s clear or not. I had water coming out on the pump side when adding water to the skimmer line. I reinstalled everything and the pump was working the best it had ever worked at 5-10psi which I still...
  18. S

    New pool owner - Pump loses prime and <1 psi

    I can’t actually tell if it’s going into the pool....I’m just assuming since it’s not coming out the other end and the only other place is the floor drains. I’m fearful of a break in the underground line but I guess I just fear the worst. I’ll keep at it! Thanks a ton for your input.
  19. S

    New pool owner - Pump loses prime and <1 psi

    Oh I also have my wet dry vac to try and blow into the line ?‍♂️ No luck there either. Should I buy a long snake or call a pro?
  20. S

    New pool owner - Pump loses prime and <1 psi

    So I got a perfect seal on the skimmer line but it also connects to the main drain lines at the bottom of the pool. I know this because when I emptied the pool and put water into the skimmer a ton of Crud came out of the 2 drains at the bottom. I’m assuming the water is blowing out of those...
  21. S

    New pool owner - Pump loses prime and <1 psi

    Tried multiple attempts and I have a ton of water coming back at me. I’m assuming it should be pushed back into the pool with relative ease if there wasn’t a blockage?
  22. S

    New pool owner - Pump loses prime and <1 psi

    So I’m trying to stick my hose down either line...skimmer and pump line and can’t get it down far enough. Found out the back line on the skimmer is blocked off and the bottom line apparently makes a quick turn as I can’t stick anything down it. Tried a long metal hanger just to see since the...
  23. S

    New pool owner - Pump loses prime and <1 psi

    Before I took my pump apart I tried it with my cartridge out of the filter. It ran slightly better....maybe 10-20%. Still really loud and about 1psi. Crossing my fingers there is some blockage in the line because the pool locked like a swamp when I got it but though I cleared most of it out...
  24. S

    New pool owner - Pump loses prime and <1 psi

    So I have one of those bladder things to clear clogs in pipes. I assume this would be ok to use? Should I spray from the pump line or in the slimmer line? Also I have 2 holes in my skimmer (no vacuum line). One on the bottom and one on the back. Does the back line connect to the floor...
  25. S

    New pool owner - Pump loses prime and <1 psi

    If the mechanical seal is the springy type thing with two orings on either end which goes on the prong on the pump before everything else installs on it then yes.....it was there but I broke it trying toput the pump back together lol. I’m going to buy a new one today.
  26. S

    New pool owner - Pump loses prime and <1 psi

    I’ll do this. I only have one intake line. It connects to the skimmer and 2 floor drains....not even sure if the floor drains have suction though.
  27. S

    New pool owner - Pump loses prime and <1 psi

    There’s my setup and some pics I’m the impeller and diffuser etc. I likely broke off that piece in the impeller trying to get the screw out. To my untrained eyes everything looked fine with the pump so now I’m leaning back to the intake line or the pump being too many hp for my filter.