Search results

  1. T

    Polaris 3900 in-line filter screen

    Yeah, I've had problems with all sorts of products being sold as OEM, so I'm pretty careful about it. It's part #42. My pool was installed about 18 months ago, the original and the replacement both split in the same manner. The result is I get a little bit of debris in the water management...
  2. T

    Polaris 3900 in-line filter screen

    My screen keeps blowing out the side. The original lasted about a year and the replacement OEM part lasted about 6 months. The screen just splits down the side. I've looked in the reviews at the replacements on Amazon and several people are having the same problem. Does anyone have a...
  3. T

    White residue ring with SWG

    New hot tub owner with SWG. Salt level is ~2400 CH is 150. I have a white ring of powder residue around the waterline of my tub. Rinses off with water and a slight rub of my finger. Is this from the salt or something I should be more concerned about? Thanks in advance, Tod
  4. T

    Alkalinity quite low, PH holding nice and steady at 7.7

    That's what I was hoping to hear! Thanks!
  5. T

    Alkalinity quite low, PH holding nice and steady at 7.7

    Hi all, I have a similar problem (or maybe it isn't a problem) as JoeCooler in previous post. Purchased a new tub, SWG, 500 gal. Got my salt adjusted, calcium in line (150ish), and some stabalizer (put enough in to get to 30 but my test kit doesn't go that low so assuming it's good). First...
  6. T

    New Build Fort Worth

    Not sure if anyone is still paying attention to this thread. The same company is doing my build right now so I asked about the partial fill after the plaster. He said that when they shoot the gunite, they make weep holes in the bottom so that if any water gets under the pool, it flows into the...