Search results

  1. C

    Pentair MasterTemp 250 runs for couple minutes then triggers Service Heater light

    Quick update: We had our technician stop by and he quickly noticed the external temperature gage was installed directly after the outlet pipe from the heater, instead of the proper way of installing the sensor before the heater. However, don't think this was the main issue. On further...
  2. C

    Pentair MasterTemp 250 runs for couple minutes then triggers Service Heater light

    Hey guys, thanks for the replies. Much appreciated. Trying hard to get to the bottom of this. To answer the questions, when we first installed it, after about a month it leaked (water) and turns out the copper coil had damage to it. It was replaced under warranty. I don't notice this...
  3. C

    Pentair Mastertemp 400 cycles heat on and off

    I've got the same problem with a MasterTemp 250. It runs for 2-3 minutes than triggers the Service Heater light. I've checked the LEDs on the board and nothing is triggered. So what could it be?
  4. C

    Pentair MasterTemp 250 runs for couple minutes then triggers Service Heater light

    It starts fine, runs for 2-3 minutes then triggers the Service Heater. I took the front panel off to see the LEDs on the board and I see nothing that is on. What would tigger the Service light if no LEDs are triggered? If I turn it off and turn it back on, it will run again for the 2-3...
  5. C

    Why does our Pentair EasyTouch controller keep switching back and forth from Pool to Spa mode?

    Hi Dave, That's interesting - I'll look into it tonight. Thanks for the suggestion.
  6. C

    Why does our Pentair EasyTouch controller keep switching back and forth from Pool to Spa mode?

    We have a new Pentair EasyTouch controller with a Leisure Pools Pool/Spa combo. It's plumbed so it can either be in Pool mode or Spa mode. I've noticed the control unit keeps switching the valves back and forth from Pool to Spa about every 20 minutes. There are no schedules set and no egg...