Recent content by Niteowl

  1. N

    Which weir door?

    Please delete this thread. I found the model number of the skimmer (SP1070B) and was able to find the weir door.
  2. N

    Which weir door?

    I was told that I should replace my missing weir door, how do I know which one I need? I looked online and there are tons of them.
  3. N

    Starting to look better...but.

    I lost this battle, the algae is hiding in places that I can't get to. At this point I am just maintaining the FC at 6-7ppm, which means adding about 48oz of LC everyday, because it drops to 0 FC overnight.
  4. N

    Looking for opinions on these 2 items

    My current filter is 90sq ft, I want to stay with the cartridge but go larger.
  5. N

    Looking for opinions on these 2 items

    I have been looking into upgrading my equipment, but was going to do it in steps as I could afford it. I decided to do the pump first as I had a little extra cash. I started putting out feelers to get quotes, one of the quotes was very interesting. He said that he could do both and stay in my...
  6. N

    To De or not to De?

    My current pump is not strong enough to run my new suction side vac. So if I get a bigger VS I could set it at a lower rpm for daily running, then pump it up to run the vac? Does it allow you to set it from the phone?
  7. N

    To De or not to De?

    The time is coming soon that I am going to pull the trigger on the new pump, I will be buying it the first week in July. PAP is having a 15% off sale on pumps right now, but it only lasts until tomorrow. I might be able to scrape the money together to get it by tomorrow, but still not sure what...
  8. N

    I messed something up...help!!!

    Next I gotta figure out why my suction went down. I bought this vacuum about a month ago, I did the suction test the day I bought it and the suction was good enough to run it. Now after having my pumbing redone and SLAM'in for 2 weeks, I have lost suction.
  9. N

    I messed something up...help!!!

    Woot...that worked. Priming it with the water hose. Thank you!!!
  10. N

    I messed something up...help!!!

    Its isn't sucking any water, I can hear the impeller going but no water coming in.
  11. N

    I messed something up...help!!!

    I was not getting enough suction on the vacuum, so I decided to check the impeller, now the pump is not working correctly. Asking here before I call someone.
  12. N

    Starting to look better...but.

    Does PAP sell the same liquid that would be in the R-0871 for the FAS-DPD test? I ran out today, I ordered some a couple days ago but won't be here until Friday. Did not want to stop SLAM. Might have to just guess at the FC and add whatever LC I think it needs. ***Even though USPS said that it...
  13. N

    Starting to look better...but.

    Annnnnndddd the saga continues...you wont believe what I forgot to do. I was sooo concentrated on testing and adjusting, and battling this algae, that I forgot the basics. Take a peek.
  14. N

    Starting to look better...but.

    It seems like the more I do, the worse it gets. Somehow I lost 13ppm while I was at work today. That's the most I have lost in a single day. After pressure washing every crack in the pool...smh
  15. N

    Starting to look better...but.

    I am sure that I took off a layer of cement in some places, to make sure there was no algae present.