Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Dolphin DX3 Power Supply

  1. Back To Top    #1

    Join Date
    Apr 2015
    Location
    Denham Springs, LA
    Posts
    44

    Dolphin DX3 Power Supply

    It appears my Dolphin power supply isn't working. Normally when I plug it in, the power lights come on and the mode light flashes until I select a mode. Then more power lights come on to indicate it's working. Now I only get the power light on, but no mode light. Pressing the power or mode buttons does nothing. Dolphin won't move. Do I need to replace the power supply? Any other thoughts? Thanks.
    19,800 gal fiberglass pool; Hayward Pro sand filter (S244T) w/ vari-flo xl valve; 1.5 hp challenger pump; Aquarite SWG w/ T-15 cell; Dolphin DX3 auto vacuum; TF-100 test kit

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,975

    Re: Dolphin DX3 Power Supply

    Hello Andrewm! I see you haven't received a reply yet on your post about the Dolphin power supply. I just wanted to let you know we haven't forgotten about you. This reply should get your posting updated back to the top of the queue where hopefully someone experienced with your specific question can provide some constructive answers. Thanks for checking-in with TFP, and have a great day.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Southeastern PA
    Posts
    20

    Re: Dolphin DX3 Power Supply

    I have a dolphin diagnostic that would not turn on anymore. To replace the power supply was pretty expensive but I took it apart and smelled the transformer. If it smells burnt, you will probably need to replace the unit. Mine was fine but the control board was shot. I was able to buy a board replacement for significantly less than an entire power supply. Might be something to look into in your case. Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •