Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Slight whistle from Pentair IntellFlo

  1. Back To Top    #1

    Join Date
    Aug 2014
    Location
    Mesa AZ
    Posts
    54

    Slight whistle from Pentair IntellFlo

    Hi - so earlier this year I got the IntelliFlo VS installed and it worked perfectly, quiet, etc...

    But about 3 weeks ago I've noticed a 'whistling' noise coming from it. Nothing too loud, just kind of a consistent whistle especially audible when it's on a low or medium speed. At high speed the motor noise overwhelms it.

    Any ideas or things I should look for? Around this same time (so in my mind it might be related, but maybe not) I had an air issue (loose lid on pump) that blew out my vacuum cleaner hose a few times and popped out my acid injector tubes as well, so I'm wondering if the backpressure knocked something loose.
    30k plaster pool
    Pentair 011018 IntelliFlo, Pentair CCP520, IC40 SWG, IntelliPH Acid system
    Easytouch 4 + ScreenLogic2

  2. Back To Top    #2
    Casey's Avatar
    Join Date
    Apr 2007
    Location
    SW PA
    Posts
    10,157

    Re: Slight whistle from Pentair IntellFlo

    Did you lube the lid? I know when the lids come off, you're suppose to lube the *O* rings with pool lube.
    I'd bet you my bikini you'll never get TFP water from a pool store!

    24' Sharkline Venture De Filter

  3. Back To Top    #3

    Join Date
    Aug 2014
    Location
    Mesa AZ
    Posts
    54

    Re: Slight whistle from Pentair IntellFlo

    No, actually I didn't. I think I will start doing that now that you mention it.

    But the whistling seems to not be caused by that and seems to come more from the back of the pump.
    30k plaster pool
    Pentair 011018 IntelliFlo, Pentair CCP520, IC40 SWG, IntelliPH Acid system
    Easytouch 4 + ScreenLogic2

  4. Back To Top    #4

    In the Industry

    Join Date
    Jul 2015
    Location
    Fairbanks, AK
    Posts
    40

    Re: Slight whistle from Pentair IntellFlo

    There is a cover at the back of the Intelliflo motors and mine came off a near where the fan is and made a slight whistle sound, I tightened it back on and it went away.
    Commercial Pool Facility| Pool 35,000Gal, Pentair Inelliflo VS, Pentair Triton II 140, CircuPool SI 35 +| Indoor Spas 12,500Gal, Pentair Intelliflo VS, Pentair Triton II 100, Circupool Si 25+| Outdoor tub 10,000 Gal, Pentair Intelliflo VS, Pentair Triton II 100, Circupool Si 25+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •