Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Saltwater pool with algae---used algaecide and now have foam!! :(

  1. Back To Top    #1

    Saltwater pool with algae---used algaecide and now have foam!! :(

    We have (maybe had, can't see the bottom of the pool for the foam now) black algae on the bottom of our pool. We were advised to use algaecide and purchased the algaecide, brushes and some "Jandy stain remover" that said it would remove the stains. We used all of these yesterday....brushed and brushed and brushed as well as used the stain remover. This morning we awoke to our pool being covered in white foam. We thought we were doing the right things, but now, we aren't so sure. Anybody have this or a similar experience? We have read where it says to just "let it run its course", but we want to use our pool...and the info does not give us any ideas of how long "letting it run its course" will last.

    Any help would be greatly appreciated!!

    Thank you!

  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: Saltwater pool with algae---used algaecide and now have foam!! :(

    Wow! Sounds like you got pool stored! Dang it! Lots of magic potions and a pool you can't swim in. Unfortunately that is the pool store way.

    SLAMing - Shock Level And Maintain your pool will take care of everything. Algae, foam magic potions, all of it.

    Get a Good Test Kit, I use the TF100 from
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts