Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: New Cell flashing Low Amps

  1. Back To Top    #1

    Join Date
    Mar 2012
    Location
    Just South of Atlanta, GA
    Posts
    18

    New Cell flashing Low Amps

    Thanks in advance for any and all help.
    First off:
    Autopilot DG-220
    I just replaced my super cell "SC-42" with a new cell "RC-42" that is what came in.
    I installed it 2 weeks ago. Now the RC-42 is flashing "Low Amps"

    I did not run the test yet as I had to hurry off to work.

    Water test last week was perfect Chlorine 3.2ppm. salt 3400. Now chems needed.

    Does the DG-220 need to be programed to the new RC-42?
    I have read that this is not the direct replacement for the SC-42 ??

    Just a little lost as it should be a Trouble Free Pool for years...not weeks.

    Thanks for any and all info!

    Dog out....
    16 x 36 IG Vinyl 27,000 gal, AutoPilot DG-220 SWG RC-42, Dolphin Premier bot.

  2. Back To Top    #2

    Re: New Cell flashing Low Amps

    There is no SC-42. There is an SC-60, which is the same size as an RC-52. There is an SC-48, which is the same size as an RC-42. If you replace a bigger cell with a smaller cell, you have to change the setting.

    Other causes of low amps can include low salt level or a bad dc power cord.

  3. Back To Top    #3

    Join Date
    Mar 2012
    Location
    Just South of Atlanta, GA
    Posts
    18

    Re: New Cell flashing Low Amps

    My typo.. it was an SC-48 and now RC-42
    Salt lvl is 3400ppm.
    16 x 36 IG Vinyl 27,000 gal, AutoPilot DG-220 SWG RC-42, Dolphin Premier bot.

  4. Back To Top    #4

    Re: New Cell flashing Low Amps

    Press menu and select "test pool pilot" to see what that says.

    Also check "view setup".

    Did you replace the dc cell cord?

  5. Back To Top    #5

    In the Industry

    JoshU's Avatar
    Join Date
    May 2007
    Location
    New Orleans, LA
    Posts
    541

    Re: New Cell flashing Low Amps

    I believe we spoke this morning by phone and I just sent you an e-mail as well so we can test the system and see what the volts and amps read.

    To confirm... AutoPilot changed the part #s for the cells several years ago however there was not a change in the design of the part.
    SC-36 = RC35/22
    SC-48 = RC42
    SC-60 = RC52
    Josh Ulfers - josh@saltpoolguys.com - 888-725-8766
    SaltPoolGuys.com - AutoPilot Pool Pilot Systems, Parts & Cells - AquaCal Heat Pumps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •