Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Laars Lite 2 wont do anything at all

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    MN
    Posts
    3

    Angry Laars Lite 2 wont do anything at all

    I have a Laars Lite II pool spa heater (LD125N) with the electric/ceramic element instead of the pilot light. We just moved into the house with this heater and have inherited all the problems that go with it. It worked fine for a few days after i completely went through it all, vacuumed everything out, replaced pressure sensor, replaced ceramic heating element, a few worn wires were replaced as well. It worked fine for a days as I said, it has the 7 second delay on the element, and 40 second ignite delay, both worked fine. Now it's as though its not even getting power anymore. The element never heats up, and just plain out nothing happens, it doesn't even make those "click" sounds anymore. I checked the power source, the source is good. I unplugged the heater and left it unplugged over night thinking maybe some sort of safety may have been tripped on the board that would reset with no power running to it. This morning still nothing happens. We have a pool party this afternoon for our daughter. I need this fixed asap. thanks for the help.
    Laars Lite 2 Pool/Spa Heater w/ electric element (no pilot)
    28,000 gal in ground Chlorine pool

  2. Back To Top    #2

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Laars Lite 2 wont do anything at all

    At this point it could be anything. You need to get a Volt/ohm meter and start checking things. since the igniter is not glowing I would start by checking the safety circuit first. If that checks out good check to see if the igniter circuit is putting power to the igniter. The leads from the board should have 120 volts when the circuit is energized.
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    MN
    Posts
    3

    Re: Laars Lite 2 wont do anything at all

    I do not have a volt/ohm meter but I will be running to the hardware store to grab one in a minute here. I bypassed all 3 safeties that I know about... I'm sorry I haven't been around pools enough to know the names of them all but I bypassed the pressure safety, the little white one that looks like about the size of 5-7 nickels stacked up, and the one at the very top of the heater near where the water enters through the PVC. And still nothing. Is it possible the board under the switches is bad?
    Laars Lite 2 Pool/Spa Heater w/ electric element (no pilot)
    28,000 gal in ground Chlorine pool

  4. Back To Top    #4

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Laars Lite 2 wont do anything at all

    If there is no schematic showing all of the wiring and associated safeties on the unit, it can be found online with a little search. It is important to have this to troubleshoot so you can follow the logic in the circuits. Without it, you are on a cross country road trip without a map/gps. As to a bad board, I do not want to hazard any guesses. I don't troubleshoot that way. I need data.
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •