Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Hayward SwimPure Plus goes lights out

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Houston, TX
    Posts
    2

    Exclamation Hayward SwimPure Plus goes lights out

    I have a Hayward SwimPure Plus SWG with a T-Cell-15. Today the LEDs on the control panel went dark. More specifically, when I turn the system on the "No Flow" LED flashes for a bit as normal. Once it stops flashing the "Generating" LED goes solid for about 10-15 secs then goes out. At this point all LEDs are unlit including the "Power" LED. There is obviously power going to the unit as the LCD Display that shows salt level and water temp among other things is completely functional. My pool is 10 years old but this specific unit is only about 2 years old. Has anyone experienced this? Any suggestions? Thanks.

  2. Back To Top    #2

    TFP Guide

    chiefwej's Avatar
    Join Date
    Jun 2011
    Location
    Tucson
    Posts
    2,853

    Re: Hayward SwimPure Plus goes lights out

    There is an input resistor on the control board that commonly burns out. The good news is it only cost a couple bucks, bad news...how good are you at soldering on a circuit board?

    Someone will be along with all the details, on how to diagnose it, and the part number and source for the part. Alternatively, you can spend a little time with Google and I'll bet you find the details.
    chiefwej
    Tucson, AZ
    16x36 rectangular (19k) Pebble Tec play pool/spa, Pentair Intelliflo VS 011018, Super II 2hp (spa), Aqua Rite T-15 SWG, Pro Grid 60 DE, Hayward H400 & Heliocol Solar heating, A&A infloor system, fill water w/high CH and TA, 50 ppm borates,TF-100 test kit

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Houston, TX
    Posts
    2

    Re: Hayward SwimPure Plus goes lights out

    Quote Originally Posted by chiefwej View Post
    There is an input resistor on the control board that commonly burns out. The good news is it only cost a couple bucks, bad news...how good are you at soldering on a circuit board?

    Someone will be along with all the details, on how to diagnose it, and the part number and source for the part. Alternatively, you can spend a little time with Google and I'll bet you find the details.
    chiefwej,
    Thanks for the quick response. I found the older thread as well as the info about the replacement part. Fortunately, I can wield a soldering iron and will be going the DIY route first

  4. Back To Top    #4

    TFP Guide

    chiefwej's Avatar
    Join Date
    Jun 2011
    Location
    Tucson
    Posts
    2,853

    Re: Hayward SwimPure Plus goes lights out

    Just as a suggestion, when replacing the resistor I just cut the legs off the old one and bent them around the legs of the new one. That makes very easy, so you aren't soldering directly to the circuit board and the new part sets at a 90 degree angle to the old one and stands off the board for better cooling.
    chiefwej
    Tucson, AZ
    16x36 rectangular (19k) Pebble Tec play pool/spa, Pentair Intelliflo VS 011018, Super II 2hp (spa), Aqua Rite T-15 SWG, Pro Grid 60 DE, Hayward H400 & Heliocol Solar heating, A&A infloor system, fill water w/high CH and TA, 50 ppm borates,TF-100 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •