Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Stenner single speed pump 45 series.makes loud squeak when running.

  1. Back To Top    #1

    Stenner single speed pump 45 series.makes loud squeak when running.

    Ive got a single speed Stenner pump, Its the 45 series and when it runs, as the rollers spin around, you can hear them forcing the pump tube to push against the housing and cause a squeak that is really loud. we can hear it inside the house through a stucco wall. Ive changed the pump tube and cleaned out the housing and still does it. I made a video on you tube that shows the problem.

    Stenner peristaltic pump squeak - YouTube

    I use this to pump diluted chlorine into return pipe for pool

    Any help will be appreciated on how to stop it. Ive sent email to technical support for Stenner but have not heard back yet.

    Sincerely,

    Reese
    22K gal, IG plaster, hayward 1500 pump, DE filter, spa, Polaris 3900

  2. Back To Top    #2
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,981

    Re: Stenner single speed pump 45 series.makes loud squeak when running.

    Hello Reese and welcome back! I see you haven't received a reply yet on your post about your Stenner. I just wanted to let you know we haven't forgotten about you. This reply should get your posting updated back to the top of the queue where hopefully someone experienced with your specific question can provide some constructive answers. Thanks for checking-in with TFP, and have a great day.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    Join Date
    Mar 2015
    Location
    Sugar Land , TX
    Posts
    388

    Re: Stenner single speed pump 45 series.makes loud squeak when running.

    This is just a wild guess but is the housing connected to the motor correctly. I would un-mount and reconnect the pump to the motor. Make sure the pump tube is seated correctly in the housing ( centered ). Here is a vid to help http://www.cannonwater.com/Products/..._video-s_.html
    8500 gallon IG Pebble Sheen with Spa. 3hp Pentair VS Intelliflo ( pool ), 3/4 hp WhisperFlo ( water feature ),Pentair Racer, 400K Pentair heater, Pentair 500sqft Cartridge filter, EasyTouch 8, Stenner 45mp2 15gallon wired to ET8

  4. Back To Top    #4

    Re: Stenner single speed pump 45 series.makes loud squeak when running.

    Well I thought I had fixed it. Seemed that the pump tube had been twisted when I tightened the Ferruls to the end which worked for a few minutes, no squeak but then came back as loud as ever. Not happy with that pump. So is this kind of a flaw with this model pump or just defective? Would I have same problem if I bought another or is there something better out there?
    22K gal, IG plaster, hayward 1500 pump, DE filter, spa, Polaris 3900

  5. Back To Top    #5

    Join Date
    Apr 2015
    Location
    Tucson/AZ
    Posts
    90

    Re: Stenner single speed pump 45 series.makes loud squeak when running.

    Quote Originally Posted by mystrwizard View Post
    Well I thought I had fixed it. Seemed that the pump tube had been twisted when I tightened the Ferruls to the end which worked for a few minutes, no squeak but then came back as loud as ever. Not happy with that pump. So is this kind of a flaw with this model pump or just defective? Would I have same problem if I bought another or is there something better out there?
    I have been looking at stenner posts for a couple of weeks before I purchased and installed mine. I have not seen any mention of the type of noise you are having - therefore, it is likely you have a defective unit. If I were you, I would contact either:

    (1) Stenner Pump Manufacturer - stenner.com/support and submit an inquiry through their support page or call their support number and discuss with them.



    (2) Contact support where you bought the Stenner pump from.


    Gary

    PS - post back here when you receive any additional information or resolve the issue.
    20,000 gal IG Plaster Irregular Shaped Pool (1987), Hayward SP3400VSP Ecostar Pump, Hayward Pro-Grid 60 SqFt DE Filter, Hayward Pool-Vac Ultra, TF100, Speed Stir, Stenner Pump & 15 Gallon Tank, Oasis Z5, and LA Spas H.E.E.T Model

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Stenner single speed pump 45 series.makes loud squeak when running.

    The most likely cause of the squeak is that one or more of the rollers are froze to the shaft and not turning as they rotate, or the roller shaft is dry and needs lubricating. If it's under warranty contact Stenner and let them send the necessary parts.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •