Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Anyone else have a Swim Spa?

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Oklahoma City, OK
    Posts
    72

    Anyone else have a Swim Spa?

    We recently bought a Master Spas H2X swim spa. I know they are not very common, so I wondered if anyone else had one. We have had some issues with balancing the water due to the spa store giving us bad information, so I am starting to handle this on my own. I ordered a Taylor bromine test kit that should be here today. I appreciate all the information on this site. It has been hugely helpful. I'm sure I will have some questions soon!

  2. Back To Top    #2
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Anyone else have a Swim Spa?

    Welcome to TFP!

    I don't have a swim spa, but have a spa. Mine uses chlorine but bromine can be used as well. Read through this thread here and if you have questions, fire away.

    How do I use Bromine in my spa (or pool)?)

    If you wanted to switch to chlorine for any reason, that's also doable in any spa.

    How do I use Chlorine in my Spa (or pool)?)
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Oklahoma City, OK
    Posts
    72

    Re: Anyone else have a Swim Spa?

    I thought I had set up my signature, but it apparently didn't work. I just thought I would reply on here so you could see it this time.

    - - - Updated - - -

    Thanks!
    1000-gallon Master Spas H2X Swim Spa. Installed June 2015.
    Started with chlorine and it went south (with awesome advice of spa dealer....insert sarcasm).
    My kids ended up with bad bacterial hot tub rash 10 days after installation.
    Dumped it and started over with bromine.

  4. Back To Top    #4
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Anyone else have a Swim Spa?

    Welcome to TFP and congrats on the new swim spa!

    We have used the dichlor then bleach process to maintain our tub for about 18 months now and are very happy with it.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  5. Back To Top    #5

    Join Date
    Jun 2015
    Location
    Oklahoma City, OK
    Posts
    72

    Re: Anyone else have a Swim Spa?

    Quote Originally Posted by pooldv View Post
    Welcome to TFP and congrats on the new swim spa!

    We have used the dichlor then bleach process to maintain our tub for about 18 months now and are very happy with it.
    Thank you! We just switched from chlorine to bromine, so I am trying to learn all I can. The spa place sure jacked ours up, so I think I am on my own. My Taylor test kit came today and I'm looking forward to using it. If only I could get the ph under control! My dumb strips always say it is low, but the spa place tests it and says it's high.
    1000-gallon Master Spas H2X Swim Spa. Installed June 2015.
    Started with chlorine and it went south (with awesome advice of spa dealer....insert sarcasm).
    My kids ended up with bad bacterial hot tub rash 10 days after installation.
    Dumped it and started over with bromine.

  6. Back To Top    #6
    Mod Squad JVTrain's Avatar
    Join Date
    Feb 2014
    Location
    Central Minnesota
    Posts
    5,079

    Re: Anyone else have a Swim Spa?

    Trust your Taylor results. As per the sticky thread, get your TA down to 50-60 by lowering pH when it gets high. Then your pH rise will slow down dramatically.

    # Sent from mobile device. Beware of brevity and spelling errors!
    Joel - TFP Moderator - Minnesota - **Become a TFP Supporter!** Helpful Links: ABCs of Pool Water Chemistry - SLAM Procedure - Chlorine/CYA Chart
    40x20 Pool: 32K Gallons * Vinyl * Bleach Chlorination * Hayward S270T Sand Filter * Pentair SuperFlo 1 HP * Teledyne/Laars Heater * AquaVac Tigershark * TF-100 w/ SpeedStir
    Isolated Spa - 345 Gallons

  7. Back To Top    #7
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Anyone else have a Swim Spa?

    Throw the strips away so you are never tempted to use them.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  8. Back To Top    #8

    Join Date
    Jun 2015
    Location
    Oklahoma City, OK
    Posts
    72

    Re: Anyone else have a Swim Spa?

    Quote Originally Posted by JVTrain View Post
    Trust your Taylor results. As per the sticky thread, get your TA down to 50-60 by lowering pH when it gets high. Then your pH rise will slow down dramatically.

    # Sent from mobile device. Beware of brevity and spelling errors!
    Thank you!

    - - - Updated - - -

    Quote Originally Posted by pooldv View Post
    Throw the strips away so you are never tempted to use them.
    I plan to. I can't believe they ever recommend them to anyone. They are completely useless if you ask me.
    1000-gallon Master Spas H2X Swim Spa. Installed June 2015.
    Started with chlorine and it went south (with awesome advice of spa dealer....insert sarcasm).
    My kids ended up with bad bacterial hot tub rash 10 days after installation.
    Dumped it and started over with bromine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •