Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Pentair Master Temp Spa Problems

  1. Back To Top    #1

    Join Date
    Aug 2013
    Location
    Huntington Beach, CA
    Posts
    54

    Pentair Master Temp Spa Problems

    I have a Pentair Master Temp that runs normally when heating the pool, but when we run it in spa mode the heater will heat for approximately one minute, then shut off for a minute and reignite for a minute repeating the process indefinitely. The pipes do shake briefly, but I have checked my chemical levels and confirmed with local pool store...everything is in ideal range. The thing I'm confused about is why it runs perfectly when in pool mode and not Spa. I checked the flow rate and they were operating at the same rate. I decided to lower the flow rate for the spa mode from 2900 to 2250 and it would only fire for about 10 seconds (maybe less). I then tried it at 3200 and extended the time to about 1:30.

    Does anyone have an idea why it's not working in Spa mode?

    Thanks for any help.

    17,000 gal pool
    Pentair Intellitouch
    Pentair IC40 Chlorinator
    Pentair Master Temp

    Southern California Location

  2. Back To Top    #2

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Pentair Master Temp Spa Problems

    By the sounds of the test you ran it needs more flow. Too little and the heat won't be pulled away as fast and it may shut down on overtemp. Can you increase the flow over 2900?
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    Join Date
    Aug 2013
    Location
    Huntington Beach, CA
    Posts
    54

    Re: Pentair Master Temp Spa Problems

    I currently have Spa mode running at 3200.

    Pool mode is set at 2900 and runs fine. Is there a difference in temp depending on what it's set at? I assume it just heats water at relatively the same temp/rate until it reaches the desired temp. Is that correct? Or does it heat hotter when set at higher temp?

  4. Back To Top    #4

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,435

    Re: Pentair Master Temp Spa Problems

    Are you sure you have all valves set correctly for spa mode? What you described is that there is a water flow issue and the heater isn't getting enough flow.

    A heater heats water period. It has not idea where the water is coming from or going to. It doesn't output water any hotter if the thermostat is set high or low. It just needs the correct amount of flow to operate.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  5. Back To Top    #5

    In the Industry

    Join Date
    Jun 2015
    Location
    Wildomar, California
    Posts
    423

    Re: Pentair Master Temp Spa Problems

    Definitely sounds like a flow rate The shaking pipes are due to low water flow which causes boiling water in the manifold, which causes the high limit switch to shut down the heater. Increase the flow rate.

  6. Back To Top    #6

    Join Date
    Aug 2013
    Location
    Huntington Beach, CA
    Posts
    54

    Re: Pentair Master Temp Spa Problems

    What should I set it at? It's set at 3200.....what's too high? (....maximum is at 3450). I'll test and see what happens.

  7. Back To Top    #7

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Pentair Master Temp Spa Problems

    Has it worked properly before this. Did something get changed recently downstream of the heated? (between the heater and spa) when you say the pump is set at 3200, is this just a setting on the controller or is there flow meter actually measuring the flow output? Do you maybe have an automatic valve that is not opening properly.
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  8. Back To Top    #8

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,435

    Re: Pentair Master Temp Spa Problems

    Since it works to heat the pool but won't when you switch the valves to spa, it has to be something in the valve settings or as others have said, something preventing the heater from getting water flow.

    Can you post a picture or two of your valves and also include how they are set for pool mode and then for spa mode.
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  9. Back To Top    #9

    Join Date
    Aug 2013
    Location
    Huntington Beach, CA
    Posts
    54

    Re: Pentair Master Temp Spa Problems

    Sorry for the late response, we were out of town. Anyway, here are a few pictures of the valves as they are set.
    /Users/Krish/Desktop/IMG_1991.JPG

    This is the valves set for Pool.
    /Users/Krish/Desktop/IMG_1992.jpg

    This is the valves set for Spa
    /Users/Krish/Desktop/IMG_1993.jpg

    - - - Updated - - -

    I'm having trouble uploading photos,no matter how small I make them?

  10. Back To Top    #10

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Pentair Master Temp Spa Problems

    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •