Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Pump keeps tripping, bad? Or water in plug?

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    Franklin, Texas
    Posts
    45

    Pump keeps tripping, bad? Or water in plug?

    Pump worked fine for 2 weeks. Then we got rain. It started tripping...just the pump not the SWG.
    We dug out an old pump and put it on. Same issue (but I think that pump "died" when we took down our old pool.)
    We're assuming both pump motors are bad and we need a new one?
    So if that's the case, what do we get? I think we have a 1,000gph intex pump. I can replace it for $42. Then they have 1500gph for 59 and 2500gph for 69. After that is the sand pumps at about $120?
    I know nothing about those though.
    Help! Is my pump dead? Will replacing it fix my issue?
    And if I need new which should I go with.
    My pool is a hand me down and not likely to last another year so I wonder if the lesser of an investment is best for now?

    5300 Gallon AG Vinyl pool
    Intex 2500g pump
    TF-50 Test Kit
    Location Texas

  2. Back To Top    #2

    TFP Guide

    Join Date
    Jun 2012
    Location
    western NY
    Posts
    1,557

    Re: Pump keeps tripping, bad? Or water in plug?

    I assume by tripping you mean the GFCI is tripping. Does this have one on the end of the cord or are you plugging it into a GFCI receptacle or GFCI breaker protected outlet? Does it turn on and run at all?
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

  3. Back To Top    #3

    Join Date
    Jun 2015
    Location
    Franklin, Texas
    Posts
    45

    Re: Pump keeps tripping, bad? Or water in plug?

    The pump (all of them) cord itself has a gfci.
    We had 3 pumps. The one that came with the pool (used) that worked fine for 2 weeks. It started tripping after rain. We put our old one on it (from years ago) and it did the same thing. We also got more rain but it did this from the get go.
    We have a 3rd pump we just put on today. It was brand new, just tiny. It's working fine other than not strong enough to maintain pressure for the SWG.



    5300 Gallon AG Vinyl pool
    Intex 2500g pump
    TF-50 Test Kit
    Location Texas

  4. Back To Top    #4
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,979

    Re: Pump keeps tripping, bad? Or water in plug?

    Generally when a GFCI trips, I suspect one of two things: Overloaded circuit (heat) or water intrusion. Since this seemed to start when it rained a lot, it would be easy to assume it's water related. But now you say you have a smaller pump that appears to be running fine correct (still running)? So that takes me back to overload.

    I guess it's process of elimination. A couple more thoughts:
    - Have you tried another outlet perhaps?
    - Any chance those first two pumps had anything exposed to the elements that would allow water to trip the circuit?
    - Some people will take their pump motors to a local shop for expert analysis and repair at a reasonable price

    As you say at the beginning, if this is the last season for this pool and you change things later, just ride it out and start with fresh equipment next time.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  5. Back To Top    #5

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: Pump keeps tripping, bad? Or water in plug?

    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  6. Back To Top    #6

    Join Date
    Jun 2015
    Location
    Franklin, Texas
    Posts
    45

    Re: Pump keeps tripping, bad? Or water in plug?

    Yes I've tried other outlets. Same thing. I have one pump plug in rice right now. I'll see if any moisture is drawn out and if it works. Otherwise I have no idea. The stupid thing says "rainproof" LOL!

    5300 Gallon AG Vinyl pool
    Intex 2500g pump
    TF-50 Test Kit
    Location Texas

  7. Back To Top    #7

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: Pump keeps tripping, bad? Or water in plug?

    Your getting water/ rain where the male plug enters the receptacle. What type of cover on the receptacle do you have?. The in use cover is for anything continuly running. A standard gfci cover do fail at times

    The gfi is doing what it supposed to do. Cut the cord off n put a gfci recept. In
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •