Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Leaking Sand Filter

  1. Back To Top    #1

    Join Date
    Jun 2015

    Leaking Sand Filter

    I have a Bacquapure sand filter that was given to me about 6 years ago. It has ran great all up till now. When I started it up this year I noticed a small leak under the split nut ring and didn't pay it much attention. About a week went by and my wife told me it was leaking and the pool level dropped. I unplugged the pump and the small leak was now spraying. I ordered a new o-ring and a new split nut ring. While it was down, I changed the sand and cleaned the laterals. I could not change the split nut ring out so I just used the old and it didn't want to come off as well. I tightened it down and did a backwash for the new sand for about 3 mins and there were no leaks. I turned the pump off and switched to filter after I did a rinse and it went to spraying like before. We have our daughters Sweet 16 this Saturday and we are stressing. Any ideas?



  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Leaking Sand Filter

    Welcome to TFP.

    Are you sure it's the seal and not a crack in the neck?

    Did you lube the seal before putting it back together? If not, I'd try that.

    If the pool is in good shape I'd just put it in bypass and run the pump in order to add chems. It won't be filtering, but at least it'll be circulating.

    It may be time for a new filter. If you go with another sand filter you can reuse the sand.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts