Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqua Rite not chlorinating

  1. Back To Top    #1

    Join Date
    Jun 2015
    Suffolk, VA

    Aqua Rite not chlorinating

    I have an Aqua Rite Electronic Chlorine Generator and it is not generating any chlorine. The Turbo Cell is 1 year old and test good at the local pool shop. The Control Panel reads Power "ON" and "Generating". The salt level is 3400 per control panel and pool store. The PH, ALK and Stablizer are within limits. Still no chlorine.

    I've pulled the PCB and it has some heat/burn marks at the base of the Current Limiter (Digi Key 570-1062-ND).

    There is only two parts to the system, the cell and the control panel. Should I replace the Current Limiter or just go with a complete new PCB? The poll store said the only other possibility is that there are phosphates in the water but it is clear (using shock and chlorine tables in skimmer) and there is no real source of phosphates near the pool.

    I've had the system for over 10 years without any issues until last year the cell went bad.



  2. Back To Top    #2

    Join Date
    Jun 2011
    Long Beach, CA

    Re: Aqua Rite not chlorinating

    Welcome to TFP!

    Turn the output to 100% and post all the diagnostic numbers. Make sure the cell is clean.

    Post your water test results.

    If it is the current limiter there is no reason to buy an expensive board when the fix is a $5 part that is easily repaired with minimal soldering skills.

    I have a strong feeling the problem is the water chemistry and there is a nascent algae problem which has been a very common problem this late spring in SWG pools. The best advice I can give you is to stay out of the pool store if you want this problem fixed without spending a good amount in the pool store and have them ruin the water chemistry with their shock and tabs. For now, use liquid chlorine to keep the pool chlorinated as that will not add any extra chemicals to the water.

    When you post the results we should have a good idea of what is causing the problem.
    16k gal plaster with raised spa, Jandy DEV60 filter, 2 HP 2-speed SHPF Jandy Stealth pump
    Hayward Aqua Rite T-15 SWCG, Jandy LXi 400k BTU NG heater, 350 sq.ft. of Sun Star solar panels, TF-100 Test Kit, Dolphin s300i Cleaner
    Test Kits . Pool Math . Chlorine/CYA Chart . The SLAM Process

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts