Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: New Hot tub owner

  1. Back To Top    #1

    Join Date
    Jun 2015

    New Hot tub owner

    We just acquired a used 2001 Baja Performance Series Hot Tub and once having an electrician hook up the power we are having a couple of issues with it. First question is : Main jets are working great but the small jets at each seat are not working, any suggestions as to what the problem could be? and Second question is: Not heating up, any suggestions on this? My control panel shows that it is heating but not getting up to set temperature.

  2. Back To Top    #2

    TFP Guide
    cowboycasey's Avatar
    Join Date
    Jul 2013
    Fletcher, OK

    Re: New Hot tub owner

    Is this your tub?
    found on this page Baja Spa Manuals

    some hot tubs have some kind of valve that when turned sends water to different jets.. look on page 13 for operation

    you would need to have the heater checked out but it sounds like it has gone bad or is so corroded that its not able to heat like its suppose to..
    Spa Heater Elements
    you might be able to call them and ask about the heater..

    hope this helps
    Pool: Intex 16x32 15000 gal, 2 speed 340042, Pentair CC320 Filter, CircuPool SJ45 Salt System, Intermatic PE653RC; Hot Tub: 650 Gal SWG Megachlor
    links: pool school * Recommended-Levels * SLAM * CYA chart * Test kits * How To Post Pictures * Poolmath * OCLT ** Support your website if we helped you :) **

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts