Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair Whisperflo Switching from low to high on its own...Circuit Board or motor?

  1. Back To Top    #1

    Join Date
    Jun 2015
    Location
    West Palm Beach
    Posts
    3

    Pentair Whisperflo Switching from low to high on its own...Circuit Board or motor?

    Installed about 2 years ago. I had to buy a 'two speed' relay for my automation system (JandyLink) when I installed it. Worked fine running at high speed for ~3 hours and then low speed for another 9. As title says, lately, it's been switching appropriately to low speed at the right time and then within a few minutes is back to full speed. If I manually push the control button on the JandyLink, it switches to low speed but again switches back to high speed.

    I'm guessing since it DOES switch to low that a) the relay works and b) the motor works, only leaving my JandyLink circuit board as the culprit but wanted to see if anyone else had heard of this problem. Thx!

  2. Back To Top    #2
    Patrick_B's Avatar
    Join Date
    Jun 2011
    Location
    Midland TX
    Posts
    15,001

    Re: Pentair Whisperflo Switching from low to high on its own...Circuit Board or motor

    I'm not really sure but I wanted to say welcome to TFP. We have other whisper flow owners I, sure will weigh in. Enjoy the forum!
    TFP Moderator
    Essential Links:
    ABC's Of Pool Chemistry, Test Kits, SLAM Your Pool
    28K Gal IG FreeForm, CLI Quartz, Pentair 36"SF & VS Pump, Dolphin M5, Rheem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •