Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Aqua rite t-cell issue

  1. Back To Top    #1

    Join Date
    May 2014
    Location
    canada
    Posts
    33

    Aqua rite t-cell issue

    So my turbo cell is not producing even a hint of chlorine. I went online and purchased a new one for a very good price.
    I purchased a t-cell 3 which is for pools under 15000 gallons. However I knew when purchasing that it may not work because I did not know what version of firmware I had on my Aquarite system.
    Anyways I got it today and began trying to change the setting on my control panel as directed by the t-cell manual. But, it is not going to work; it does not have the option to switch to a different type of cell. So I assume I have the old firmware which means technically I will have to buy another t-cell 15 which runs about $800 opposed to the 400 I paid for the t-cell 3.
    My question is, if I just install the t-cell 3 without being able to change the control panel will it still produce chlorine for me? Is it just the other diagnostics that won't work? If so I can live with all the diagnostic info not working as long as it chlorinated my pool.
    Or, am I going to have to return this stupid thing and spend twice the money?
    13,000 in ground saltwater, Hayward pro series sand filter, Hayward super pump, aqua collection turbo cell.

  2. Back To Top    #2

    Join Date
    Jun 2015
    Location
    Plano
    Posts
    2

    Re: Aqua rite t-cell issue

    Dang, I just bought a new T-Cell3 for $219 on Amazon.

  3. Back To Top    #3

    Join Date
    May 2014
    Location
    canada
    Posts
    33

    Re: Aqua rite t-cell issue

    I know it's likely a stupid question but can someone with the knowledge please chime in?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •