Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Powerflow Matrix Shaft Seal

  1. Back To Top    #1

    Join Date
    Jun 2015

    Powerflow Matrix Shaft Seal

    I am hoping someone can verify I am looking in the right place. I noticed that the back of my pump (motor end) was running a decent amount of water out of it. So I figured I needed to replace the shaft seal assembly. Being fairly handy, I replaced that with no problem. Now I am getting drips (every second or two) in the middle of the pump. I thought maybe I didn't seat the seal correctly, so I redid it. Same results. I replaced the strainer O-Ring, same result. I have not replaced the housing O-Ring yet, but I guess that is next.

    Could there be something else? Could I have ruined the new ceramic seal when I was pushing it? I am at a loss of what to try next. The leakage is significantly less then before, but the constant drips needs to be fixed.

    Thanks in advance,


  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: Powerflow Matrix Shaft Seal

    Welcome to TFP!

    Sorry nobody has responded to you. Here is a
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts