Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aqua Rite generating when pump off?

  1. Back To Top    #1

    Join Date
    May 2015
    Clearwater, FL

    Aqua Rite generating when pump off?

    I just checked my Aqua Rite generator with the pump off and the green generating light is on. Shouldn't the no flow light be on and the generating light be off when the pump is not on? I have been fighting really high chlorine levels in my pool and I'm wondering if this part of the problem. Is it generating chlorine when the pump is off? Thanks!
    13,600 gal. IG Pebble Sheen, new interior finish Feb 2015, screen enclosure over pool, 2 sheer descent waterfalls, Hayward SWG, cartridge filter, TF 100

  2. Back To Top    #2
    n240sxguy's Avatar
    Join Date
    May 2014
    Benton, KY

    Aqua Rite generating when pump off?

    It should be wired on the same circuit that is turning the pump off so it can't even try to generate chlorine when the pump isn't running. Sounds like the flow switch is bad and it's generating chlorine all the time. That's not good for anyone. They also make hydrogen as part of the process, so you can have a big hydrogen bubble develop. That is not good at all. Remember the Hindenburg?

    Sent from my iPhone using Tapatalk
    33K gallon IG vinyl. 1.5HP Waterway Mustang pump. 600 lb sand filter. Polaris 280. Circupool SI-60+. TF-100XL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts