Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: mystery clicking noise in multi fuinction valve

  1. Back To Top    #1

    mystery clicking noise in multi fuinction valve

    Hello everyone.. I had to replace my pump and just started up the new one and immediately noticed a definite clicking sound in the valve when in filter of backwash mode only.Did a brief backwash.Sounds like a small pebble or something Do not want to run it as is. please advise. If advice is to remove top of valve please be specific about what to do like drain filter or where to position the valve. filter is 3 yrs old..thanks

    filter is DE4820

  2. Back To Top    #2

    Join Date
    Feb 2008
    Location
    Milford, CT
    Posts
    333

    Re: mystery clicking noise in multi fuinction valve

    There could still be air in the system from when the new pump was started. My valve makes this noise if the pump loses prime (i.e. I open the pump basket to clean it).

    Eventually the air works itself out of the system and the valve noise goes away.

    Ive found that for whatever reason or another, running the filter with the valve in Recirculate helps the air work itself out faster....just keep in mind if you do that, the water is not actually being filtered, its just coming into the multiport and right back out the valve outlet.
    22K IG vinyl, .5HP Northstar pump, S244T filter, AutoPilot Digital w/SC-48 cell

  3. Back To Top    #3

    Re: mystery clicking noise in multi fuinction valve

    Ok Will do the recirculate... there is a lot of air..have bled it a few times till i got a nice stream and there is some again as i just looked..new basket nothing in it..Good vacum no bubbles in see through top of pump---so just let it run and bleed it off a lot..Where is all this air coming from..Howe long you think it should take..no bubbles to speak of coming out of return to pool..thanks

  4. Back To Top    #4

    Join Date
    Feb 2008
    Location
    Milford, CT
    Posts
    333

    Re: mystery clicking noise in multi fuinction valve

    Quote Originally Posted by Steve S View Post
    Ok Will do the recirculate... there is a lot of air..have bled it a few times till i got a nice stream and there is some again as i just looked..new basket nothing in it..Good vacum no bubbles in see through top of pump---so just let it run and bleed it off a lot..Where is all this air coming from..Howe long you think it should take..no bubbles to speak of coming out of return to pool..thanks
    If you dont see any bubbles in the pump basket and the water coming out of the return jets, chances are its just air that was inside the filter. Its possible it could be sucking air in where the pump outlet connects to the filter inlet ("venturi effect" i think ? ) so check that connection. Other than that Im not sure what else it would be.

    I have a sand filter so I usually leave the drain plug open for a bit when I first start everything up for the season. When i start getting a steady stream of water coming out of it, I put the cap on. I think a DE filter would work differently than mine.
    22K IG vinyl, .5HP Northstar pump, S244T filter, AutoPilot Digital w/SC-48 cell

  5. Back To Top    #5

    Re: mystery clicking noise in multi fuinction valve

    might be.. I had to get the pump up and running as it was not filtering for at least 1 day.and I have little time for this. The guy that did the liner also "replumbed" by the filter.. the idiot left me with no way to remove the pump but to cut it out. With no room for error. Permanently affixing glued in fittingds would mean re-plumbing the whole thing ifr it had any problems. I had to cut the pipe coming out of the pump to remove the pump.The pipe supplying the water from the pool to the pump was not level with the ground. It was pointing up a little so I used 2 of these one 2 inch into the pump and 1 1/2 coming out of the pump,neither lined up perfect.
    Fernco 1-1/2 in. EPDM Rubber Shielded Coupling-P3000-150 - The Home Depot

    Not ideal I know.

    Installation was a pain..I had to slide the pump in with the motor end raised a little and at the same time make sure both fittings lined up and went in together. I could kill that guy.

    Since no bubbles in the pump I will check the 1 1/2 pipe to the filter. It is not leaking but could be sucking air I suppose

  6. Back To Top    #6

    Re: mystery clicking noise in multi fuinction valve

    Tiny leak where the water exits the pump. I had to tighten it up before I installed it.Don't think it will take another full turn.made it tight but not tight enough I guess. Mysteriously, I had more bubbles in the pump [even though I changed the gasket] and from the return lines into the pool before i changed the pump and yet no noise from the valve then. This leak is not much.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •