Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Help - Sand Filter won't drain

  1. Back To Top    #1

    Join Date
    May 2015
    Marion, KY

    Help - Sand Filter won't drain

    I'm really hoping this is some stupid thing I've forgot, but I'm changing my sand due to a Baqua to chlorine conversion. I've taken the plug out of my sand filter, and no water is draining. I've taken the top off and it's full of water. What am I missing?????
    19,300 AG, Sand, Millennium filter and hrpwr pump, TFTestkits TF-100

  2. Back To Top    #2
    Mod Squad tim5055's Avatar
    Join Date
    May 2014
    Columbia, SC

    Re: Help - Sand Filter won't drain

    Baquagoo has plugged up the screen inside the drain plug would be my guess.
    TFP Moderator 39 X 18 23,000(ish) freeform gunite; built 2007ish; Pentair Triton II TR100 600lb Sand filter; 2 HP Pentair pump with 2.2 HP AO Smith single speed motor; 2 skimmers, 1 main drain, 4 returns w/waterfall, Stenner 45MHP2 3GPD running@ 60% - 15 gal Tank; heated by the sun CYA 200+ when I started - 50 now. Dolphin Supreme M5 Pool Cleaner. Hot Springs SX Spa, 285 gallon

  3. Back To Top    #3
    Mod Squad kimkats's Avatar
    Join Date
    Jul 2012
    Tallahassee, FL

    Re: Help - Sand Filter won't drain

    I had to use my shop vac to take my sand out. I could NOT get it to drain from the bottom either

    Be very careful with the laterals on the bottom. Do not break them or crack them.

    I had my shopvac in my wheelbarrow and just dumped it into the wheelbarrow when it was full.

    TFP Moderator 33x52 round AG 25,600 gals Sand Filter 1.5hp Pump - 2 Speed, SLAM, Pool School, Recommended Levels, Recommended Chemicals, Pool Math, Chlorine/CYA Chart, TF-100 Test Kit, Become a TFP supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts