Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Sand Filter Leaking

  1. Back To Top    #1
    off2theocean's Avatar
    Join Date
    Sep 2014
    Location
    North Carolina
    Posts
    12

    Sand Filter Leaking



    Hi,

    I have noticed that my sand filter is leaking from under the multiport and under the band where it connects to the tank. It is only leaking on one side. Is there an easy fix for this? It is a not really a leak - more like a slow seep. I haven't noticed any pressure changes. There is also no water leaking out of the backwash hose so I think the multiport is fine.

    The PB changed the sand in the filter after the replaster. I don't know if that had anything to do with it.
    Near Winston-Salem, North Carolina
    33,000 IG Freeform Gunite * Pentair Tagelus Sand Filter * Hayward Pump
    1970's Build * Resurfaced 2015 w/Krystal Blue Krystalkrete
    Polaris 380 Cleaner * TF-100 Test Kit

  2. Back To Top    #2
    Mod Squad tim5055's Avatar
    Join Date
    May 2014
    Location
    Columbia, SC
    Posts
    8,494

    Re: Sand Filter Leaking

    To be honest, a small weap like that would not bother me and I would just let it go. Sometimes the fix is worse than the problem.

    To fix it you would take everything apart, and lube the o rings or replace them.
    TFP Moderator 39 X 18 23,000(ish) freeform gunite; built 2007ish; Pentair Triton II TR100 600lb Sand filter; 2 HP Pentair pump with 2.2 HP AO Smith single speed motor; 2 skimmers, 1 main drain, 4 returns w/waterfall, Stenner 45MHP2 3GPD running@ 60% - 15 gal Tank; heated by the sun CYA 200+ when I started - 50 now. Dolphin Supreme M5 Pool Cleaner. Hot Springs SX Spa, 285 gallon

  3. Back To Top    #3
    off2theocean's Avatar
    Join Date
    Sep 2014
    Location
    North Carolina
    Posts
    12

    Re: Sand Filter Leaking

    Thanks! That makes me feel better.
    Near Winston-Salem, North Carolina
    33,000 IG Freeform Gunite * Pentair Tagelus Sand Filter * Hayward Pump
    1970's Build * Resurfaced 2015 w/Krystal Blue Krystalkrete
    Polaris 380 Cleaner * TF-100 Test Kit

  4. Back To Top    #4
    Mod Squad tim5055's Avatar
    Join Date
    May 2014
    Location
    Columbia, SC
    Posts
    8,494

    Re: Sand Filter Leaking

    Another thing I have thought of with mine is that it may be condensation, not a leak.
    TFP Moderator 39 X 18 23,000(ish) freeform gunite; built 2007ish; Pentair Triton II TR100 600lb Sand filter; 2 HP Pentair pump with 2.2 HP AO Smith single speed motor; 2 skimmers, 1 main drain, 4 returns w/waterfall, Stenner 45MHP2 3GPD running@ 60% - 15 gal Tank; heated by the sun CYA 200+ when I started - 50 now. Dolphin Supreme M5 Pool Cleaner. Hot Springs SX Spa, 285 gallon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •