Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Two Return Jets Not Working

  1. Back To Top    #1

    Join Date
    Jun 2010
    Location
    Toronto, Canada
    Posts
    34

    Two Return Jets Not Working

    I started opening my pool yesterday and after adding some water I turned on the filter and added chlorine to shock the pool. Today I went out and noticed that 2 of my 4 return jets are not pushing out any water. Specifically, the 2 return jets on the main stairs are working while the shallow end and deep end jets have no water coming out. I didn't check these two jets yesterday so I'm not sure if it was like that from the start or if this started sometime in the last 24 hours. I did backwash today when the filter pressure started to rise, but that didn't help any.

    Any advice on what my next steps should be. I've never had an issue with any of my return jets over the years.
    20,000 Gallons Inground Vinyl Pool, 1 skimmer, 1 floor drain, 4 return jets, 1 vacuum intake
    Hayward Vari-Flo XL sand filter (SM2506T), Hayward EZ Flow Pump (SP-3107X10), Emerson Pump Motor (EB228), Hayward Comfortzone NG Heater, Hayward Chlorinator (CL220)

  2. Back To Top    #2
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Re: Two Return Jets Not Working

    Hello,
    Are there any valves that control flow to those jets? You might try turning off the pump, unscrewing the jet, and running water back through the line, it may be clogged.

    Can you provide any pictures?
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

  3. Back To Top    #3

    Join Date
    Jun 2010
    Location
    Toronto, Canada
    Posts
    34

    Re: Two Return Jets Not Working

    Hi bobodaclown,

    Right before the water enters my pump/filter, there are the following three control valves:

    1) Skimmer
    2) Vacuum
    3) Drain

    My vacuum valve is off as I never use it. The Skimmer and Drain lines are pulling water in as I've tested each individually and the flow out the two returns at the stairs is quite strong. I actually blocked both these stair return Jets this weekend and still nothing came out of the other two returns.

    How do I run water back through the line? Would I just stick a hose into the Jet hole and turn it on or do I need something stronger like a shop-vac, compressor to push the water back using air?
    20,000 Gallons Inground Vinyl Pool, 1 skimmer, 1 floor drain, 4 return jets, 1 vacuum intake
    Hayward Vari-Flo XL sand filter (SM2506T), Hayward EZ Flow Pump (SP-3107X10), Emerson Pump Motor (EB228), Hayward Comfortzone NG Heater, Hayward Chlorinator (CL220)

  4. Back To Top    #4
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,994

    Re: Two Return Jets Not Working

    Last time I saw a post about this type of issue it turned out to be collapsed flexPVC pipe. There is no way for debris to get into that line to clog it unless there was a catastrophic failure in the filter. The water in the return lines is coming from the filter.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  5. Back To Top    #5

    Join Date
    Jun 2010
    Location
    Toronto, Canada
    Posts
    34

    Re: Two Return Jets Not Working

    I meant to post earlier, but I've been swamped with work. Anyway, I feel like an idiot as the issue ending up being a valve turned off on my return lines after the pump. I had never really paid attention to this area of my plumbing, but I have two main return branches after the pump/filter/heater. The first one leads to the stair return jets, but has no valve so the stairs will always have water pumping when the pump is running. The second leads to the shallow and deep ends return jets, but it has a shutoff valve. I guess last fall I turned this to the off position and forgot about it. I've never touched it before so I've added this to my opening /closing spreadsheet.

    bobodaclown,I now see you were asking about the return jets after the pump while I was thinking you meant before the pump. Thank you and everyone who responded here.
    20,000 Gallons Inground Vinyl Pool, 1 skimmer, 1 floor drain, 4 return jets, 1 vacuum intake
    Hayward Vari-Flo XL sand filter (SM2506T), Hayward EZ Flow Pump (SP-3107X10), Emerson Pump Motor (EB228), Hayward Comfortzone NG Heater, Hayward Chlorinator (CL220)

  6. Back To Top    #6
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Lakeland, FL
    Posts
    2,351

    Re: Two Return Jets Not Working

    All's well that ends well.
    17K Kidney Shaped Pool Concrete (Diamond Bright) Pool, 3/4 hp 2 speed 115V Sta-rite Duraglas PEA5D-180L/P2R5D-181L (Impeller C105-92PS Diffuser C1-216P), 1.5 piping, Pentair CC100 Filter , Heat Siphon 100K BTU Heat Pump Pool Heater, Flow meter Blue White Flowmeter Model No. F-30150P, Hayward Astrolight SP0581N, SWCG CalimarTitanium Edition TE45 , Dolphin Nautilus Plus with CleverClean, Lakeland Florida

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •