Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: CS8110 Intex unit GFCI does not work?

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Havre de Grace, MD
    Posts
    2

    CS8110 Intex unit GFCI does not work?

    Hi everyone. I have an Intex CS8110 unit, and I think the GFCI has stopped working. It does not reset, and the test button does not work. There also is no power to the unit. Any ideas to fix this? Last year it worked like a champ. Just tried to open the pool and turn it on yesterday.

  2. Back To Top    #2

    TFP Guide

    Azgirl71's Avatar
    Join Date
    Apr 2015
    Location
    Sierra Vista, Az
    Posts
    2,586

    Re: CS8110 Intex unit GFCI does not work?

    Have you checked the GFCI outlet it is plugged into? Mine has tripped before and I have had to rest it a few times and then re set the one on the plug.
    Lisa
    Intex AG vinyl 15' x 48" 4,300 gallons due to skimmer install, Krystal Clear SF pump combo 2800 GPH, Krystal Clear SWG, Pool Blaster Max vacuum, Hayward thru the wall skimmer, TF 100 test kit with speed stir, K 1766 Taylor salt test, My SLAM Process

  3. Back To Top    #3
    Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    12,966

    Re: CS8110 Intex unit GFCI does not work?

    Well, electricity can be tricky for sure. Process of elimination would drive me want to confirm is it actually the GFCI outlet that's bad, or perhaps something in your Intex unit that is keeping the outlet from resetting? Have you tried unplugging the Intex pump and plugging-in some other electrical item in its place? Just to see if the circuit stays on? If the outlet still is not working, it's always possible it's the outlet itself that's bad in which case you would need to replace it. I'm assuming go back to your main sub-panel, turn-off power to that circuit/outlet, and replace it. But let's see if anyone else replies who may have had some similar experiences.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  4. Back To Top    #4

    Join Date
    May 2015
    Location
    Havre de Grace, MD
    Posts
    2

    Re: CS8110 Intex unit GFCI does not work?

    Thank you for the responses! Yeah... I have tried multiple outlets. The GFCI itself isn't resetting, even when unplugged. It's either the cord, or the saltwater unit. REALLY don't want to buy a new unit!

  5. Back To Top    #5


    TFP Guide
    jeffchap's Avatar
    Join Date
    Jun 2012
    Location
    Edmond OK
    Posts
    1,373

    Re: CS8110 Intex unit GFCI does not work?

    What a coincidence! I got home last night and mine was off too! I have the same model, and this is the first time it's ever done this before.



    Upon close inspection, the plastic enclosure for the GFCI is cracked, and since we've had monsoon season lately, I'm guessing water has gotten into it. I was able to press reset a few times and it finally came back on. But after my external timer clicked over, it wouldn't come back on again without more fiddling.



    Since my entire circuit is GFCI protected, I'm probably just going to cut it off and put a plain plug on the cord. I had to do this with the pump, because every time the external timer kicked on, it would trip the GFCI built into the pump's cord.



    I use an external timer for the pump and SWG because it gives me more flexibility as to when I want them to run.
    25000 gallon free-form gunite
    Jandy Stealth pump/CL340 cartridge filter
    Pentair IC40 SWG
    Pentair MasterTemp 250HD heater
    Jandy AquaLink RS automation

  6. Back To Top    #6


    TFP Guide
    jeffchap's Avatar
    Join Date
    Jun 2012
    Location
    Edmond OK
    Posts
    1,373

    Re: CS8110 Intex unit GFCI does not work?

    Update - I removed the GFCI and installed a regular grounded plug and the SWG powered back up and is working fine now.
    25000 gallon free-form gunite
    Jandy Stealth pump/CL340 cartridge filter
    Pentair IC40 SWG
    Pentair MasterTemp 250HD heater
    Jandy AquaLink RS automation

  7. Back To Top    #7

    Join Date
    Jun 2017
    Location
    Walton, KY
    Posts
    23

    Re: CS8110 Intex unit GFCI does not work?

    Quote Originally Posted by jeffchap View Post
    Update - I removed the GFCI and installed a regular grounded plug and the SWG powered back up and is working fine now.
    Can this be done by someone with little to no electrical skills? I believe I am having the same problem as my Intex CS8110 SWG will turn on only sporadically. Sometimes I go out and it's fine, and sometimes I go out and nothing I do will get it to turn on.

    If this is easily done, can you post instructions? Preferably instructions that assume I know NOTHING because in this case, I really don't.

    Thanks!
    10,000 gal above ground pool. Salt water generator model Intex CS8110. Hayward cartridge filter.

  8. Back To Top    #8


    TFP Guide
    jeffchap's Avatar
    Join Date
    Jun 2012
    Location
    Edmond OK
    Posts
    1,373

    Re: CS8110 Intex unit GFCI does not work?

    25000 gallon free-form gunite
    Jandy Stealth pump/CL340 cartridge filter
    Pentair IC40 SWG
    Pentair MasterTemp 250HD heater
    Jandy AquaLink RS automation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •