Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aqualink RS8 Strange Behavior

  1. Back To Top    #1

    Aqualink RS8 Strange Behavior

    I have an in-ground pool that we built about 11 years ago with an Aqualink RS8 control system with an All Button in house control. The system also has an 8-button SpaLink remote that is working fine (displays temps and buttons all work) and is about 6 years old. Two years ago I upgraded to an iAqualink compatible system board (rev R) that is also functioning properly and has never caused me any issues.

    The strange behavior I'm observing (which started sometime during the winter months) is that every day or two, seemingly in the middle of the night when all devices are off, some combination of the AUX4-7 buttons will illuminate and become inoperable. I only have AUX4-5 actually connected (pool and spa lights) and the others are not connected to anything. Once it gets in this mode, I basically need to power off the system and then everything will start back up properly, until a day or so later when it gets back into this strange mode.

    It seems to be a random combination of the AUX4,5,6,7 lights that come on. For example, when it happened today all 4 of them came on. When they come on, they don't also turn on what they are controlling (lights don't come on) - they are just inoperable until reset. Touching the buttons does nothing. Trying to toggle the buttons using the iAqualink interface also does nothing.

    BTW, when I cycle through the diagnostics on the All Button system, it lists out everything that is connected (CONTROL PANEL #1, SPA LINK #1, iAqualink Wifi #4, AIR SENSOR OK, WATER SENSOR OK, SOLAR SENSOR OPENED) - I don't have a solar heater so not sure if that solar sensor message is to be expected.

    Any thoughts on what might be going on?

    Thanks so much in advance.


  2. Back To Top    #2

    Re: Aqualink RS8 Strange Behavior

    I did more searching on the site and found another thread about this problem:

    I've just tried adjusting the RS 485 priority of the All Button control and iAqualink (to 4 and 2 respectively) to see if that affects anything. I didn't chose priority 1 as I already have 2 devices at that priority (my Aquarite and Spalink) which don't seem to have adjustable priorities. I'll post back in a few days with any updates.


  3. Back To Top    #3

    Re: Aqualink RS8 Strange Behavior

    Just wanted to add a quick follow-up to my thread to say that it appears that adjusting the priority solved my problem. I currently have the following priorities set in my system:

    AquaPure 1
    SpaLink 1
    iAquaLink WiFi 2
    Control Panel 4

    I'll post back if things change, but usually I get into the strange state within 24 hours and it has been 3 days already.


  4. Back To Top    #4

    Re: Aqualink RS8 Strange Behavior

    I have been having this issue for a few months. I adjusted my priorities as follows:

    SpaLink 1
    iAqualink WiFi 3
    Control Panel 4

    Just had Aux 4-7 light again this morining. Has anyone been able to come with a definite fix to this problem yet?

    - Brian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts