Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Both WHisperflo pumps leaking at water inlet

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Phoenix, AZ
    Posts
    2

    Both WHisperflo pumps leaking at water inlet

    Hello, sorry if this has been covered.

    I have a 12 year old pool that has needed both pump motors replaced in teh last three years. Now the PVC at the inlet is leaking on both teh filter & PSS2000 cleaning system inlets. They have a kind of "caulk" like material that is flaking off. After some searching I think/hope they are the screw type as opposed to glue type but would appreciate input as to how to proceed.

    I cut of & replaced the bottom of the PSS distribution system after it broke off where teh toop cover attached so have no problem cutting/glung together the pvc if that is necessary. I just want to fix it properly/

    Thanks






  2. Back To Top    #2
    n240sxguy's Avatar
    Join Date
    May 2014
    Location
    Benton, KY
    Posts
    1,800

    Re: Both WHisperflo pumps leaking at water inlet

    The top is the outlet of the pump, and should be a threaded fitting. That is probably some type of pipe dope/seal and they used on it when it was put together. You could cut the straight pipe after the 90 and unscrew it. You may be able to clean that piece off and reuse it. Just put in a union on the straight pipe to reassemble it. If it can't be cleaned up, you can just remake that piece up to the new union.


    30K gallon IG vinyl. 1.5HP 2-speed Waterway Mustang pump. 600 lb sand filter. Polaris 280. Circupool SI-60+. TF-100

  3. Back To Top    #3

    Join Date
    May 2015
    Location
    Phoenix, AZ
    Posts
    2

    Re: Both WHisperflo pumps leaking at water inlet

    Thanks so much!

    I appreciate your time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •