Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: New Motor Trouble Installing

  1. Back To Top    #1
    beachinmoney's Avatar
    Join Date
    Jun 2013
    Location
    Buckeye, AZ
    Posts
    159

    New Motor Trouble Installing

    Hi, I got a B2977 motor for my Hayward SP4010NS pump. It is longer then the old motor which is like a B128. Correction, I looked at Century site and it says they are the same. How can he be having this problem? .... The motor I got is a lot longer and that is the trouble we are having getting it to fit. Any comments help.

    I came back to correct, after reading all the stuff on Century's site including the dimensions. I need help now installing my pump. It's been two days without it and my roommate is being a 2 year old and not willing to help. I was worried this would happen.
    Beachinmoney, live in AZ, Pool is inground approx. 14,500 gallons of water. I have a Pentair Intelliflo 2 VST pump. The pool was built in 2006 and Pentair Clean and Clear Plus Filter System. A&A in-ground cleaning system

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New Motor Trouble Installing

    So what is the problem? You are going to have to be more specific and maybe add pictures.

    BTW, you should be maintaining the FC levels still and just brush really well to keep the bleach mixed.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3
    beachinmoney's Avatar
    Join Date
    Jun 2013
    Location
    Buckeye, AZ
    Posts
    159

    Re: New Motor Trouble Installing

    It's dark now, I don't really understand, he just couldn't get it to fit when he tried to insert the motor assembly into the pump housing. I will take pictures in the am...
    Beachinmoney, live in AZ, Pool is inground approx. 14,500 gallons of water. I have a Pentair Intelliflo 2 VST pump. The pool was built in 2006 and Pentair Clean and Clear Plus Filter System. A&A in-ground cleaning system

  4. Back To Top    #4
    beachinmoney's Avatar
    Join Date
    Jun 2013
    Location
    Buckeye, AZ
    Posts
    159

    Re: New Motor Trouble Installing

    It's in and working. I want to really thank you and everyone else for all the help.

  5. Back To Top    #5
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New Motor Trouble Installing


    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •