Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Blank LCD on SP3400VSP Pump

  1. Back To Top    #1

    Join Date
    May 2015
    Location
    Oldsmar, FL
    Posts
    3

    Blank LCD on SP3400VSP Pump

    I noticed my SP3400VSP did not start up this morning. I examine the pump and there appears to be power on the LCD display but the screen is completely blank.

    I have powered off the breakers and powered back with no luck.

    Has anyone encountered this issue before on a Hayward SP3400VSP?

    Is there some combination of buttons that can reset the unit?

  2. Back To Top    #2
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,998

    Re: Blank LCD on SP3400VSP Pump

    Hi, welcome to TFP.

    Hopefully someone will be along soon to help.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  3. Back To Top    #3
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,487

    Re: Blank LCD on SP3400VSP Pump

    Have you verified that there is power to the pump (i.e. measured with a volt meter)?

    Is the pump drive on surge protection and did you change that?

    Any power outages recently?
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  4. Back To Top    #4

    Join Date
    May 2015
    Location
    Oldsmar, FL
    Posts
    3

    Re: Blank LCD on SP3400VSP Pump

    Quote Originally Posted by mas985 View Post
    Have you verified that there is power to the pump (i.e. measured with a volt meter)?

    Is the pump drive on surge protection and did you change that?

    Any power outages recently?
    Yes, this is occurring when we get outages during Florida thunderstorms.

  5. Back To Top    #5
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,487

    Re: Blank LCD on SP3400VSP Pump

    Is the pump on surge protection?
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

  6. Back To Top    #6

    Join Date
    May 2015
    Location
    Oldsmar, FL
    Posts
    3

    Re: Blank LCD on SP3400VSP Pump

    Quote Originally Posted by mas985 View Post
    Is the pump on surge protection?
    No, it is not currently.

  7. Back To Top    #7
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,487

    Re: Blank LCD on SP3400VSP Pump

    It sounds like the drive fried during the storm. One of the downsides of a VS pump is that they are susceptible to power surges.

    However, you may want to double check the power going to the pump to make sure it is getting power.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •