Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

  1. Back To Top    #1

    Join Date
    Apr 2015
    Location
    hamburg
    Posts
    6

    Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    Have an inground pool with a spa. Sta-rite heater with in-house and a spa side controls. Opened pool for the season and everything looked fine. Sta-rite heater Aux-1 controls pool lights to pool and spa. Aux-2 controls spa blower. When I press the Aux-1 it lights up green on heater but nothing happens. Same as the Aux-2 button, green light comes on but nothing happens. I did replace GFCI on the side of breaker box but did not solve the problem. I noticed a "clicking" noise coming from the electrical box every time the Aux-1 and Aux-2 buttons are pressed. It seems to be coming from the relay switches in electrical box. Any thoughts? Any Suggestions? Thanks in advance.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    You keep saying heater, but you must mean automation system.

    The clicking is completely normal. I imagine that you must mean that the pool light and spa blower don't turn on.

    The most likely possibility is that a circuit breaker has tripped somewhere. For anything more complex than that you will need to have a multi-meter and trace how far power gets and where there stops being power heading to the light and blower.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Apr 2015
    Location
    hamburg
    Posts
    6

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    the blower breaker is shared 20 amp with the pump. The pump works fine. Also, I checked all the breakers, removed them and they seem to check out. Just stumped. Will trace the power but seem weird its both Aux 1 and 2. thanks for the input

  4. Back To Top    #4

    Join Date
    Apr 2015
    Location
    hamburg
    Posts
    6

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    Quote Originally Posted by JasonLion View Post
    You keep saying heater, but you must mean automation system.

    The clicking is completely normal. I imagine that you must mean that the pool light and spa blower don't turn on.

    The most likely possibility is that a circuit breaker has tripped somewhere. For anything more complex than that you will need to have a multi-meter and trace how far power gets and where there stops being power heading to the light and blower.
    Ran a trace and the spa side control was the problem. The housing and conduit had water in it. Blew the water out of the line. Aux2 for the lights now works But Aux 1 that controls the silencer spa blower does not. Does the blower has a shutoff?

  5. Back To Top    #5

    In the Industry

    Join Date
    Mar 2011
    Posts
    441

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    Jasonlion some of the older max e temps had a pool/spa/aux controller built in.
    20X40 30,000 gallon gunite pool

  6. Back To Top    #6
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    The blower would not normally have a separate shutoff, but it is conceivable that someone put one in.

    The next thing to check would be to see if power is reaching the blower. If so, there is a problem with the blower it's self. If not the problem must be with something further back.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. Back To Top    #7

    Join Date
    Apr 2015
    Location
    hamburg
    Posts
    6

    Re: Sta-Rite Heater Aux-1 and Aux 2 create a "clicking" noise

    The blower does have power. How do you check to see if blower is bad? Or just assume that it is bad because it has power? No noise coming from blower. Does not do anything.
    Also, what is another recommended replacement blower? It is a 1hp Silencer blower. Pool side spa is about 25 feet from equipment and spa is 7ft round with 6 jets. Thanks for all the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •