Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Small Drip on Multi Port

  1. Back To Top    #1
    brmommy's Avatar
    Join Date
    Jul 2013
    Location
    Southeast Ohio
    Posts
    74

    Small Drip on Multi Port

    I opened the pool and finished bringing the water level back up. No leaks on any connections except for a slow drip on the bolt of the Multi Port. I tightened it a little but it seams tight. Not sure what is inside. Any ideas? I'm afraid to tighten it much more. Here is a pic.
    boltleak.jpg
    27' Round X 54" Aqua Leader Sentinelle AGP, Vinyl J hook liner. 18,500 gal.
    Waterway 19" oval sand filter, US Motors EZBN25 1.0 hp 1.5 SPL Pump, BBB (Empty Aqua Smarte System connected, may use during vacation), Barracuda Zodiac 1500,
    Taylor FAS-DPD K-2006 Test Kit.

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Small Drip on Multi Port

    Most likely that is a result of a bad o-ring that seals the lid to the body of the valve.

    How old is the valve? If it is fairly new I would suspect a manufacturing defect. If it is older, the o-ring just needs to be replaced.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    brmommy's Avatar
    Join Date
    Jul 2013
    Location
    Southeast Ohio
    Posts
    74

    Re: Small Drip on Multi Port

    I bought this July 2013. Do the bolts come out to replace it? This is different then the large o-ring that goes where it screws onto the sand filter tank? The pool store where I bought the pool put it all together. They were each working on something different and I couldn't watch how they did everything.
    27' Round X 54" Aqua Leader Sentinelle AGP, Vinyl J hook liner. 18,500 gal.
    Waterway 19" oval sand filter, US Motors EZBN25 1.0 hp 1.5 SPL Pump, BBB (Empty Aqua Smarte System connected, may use during vacation), Barracuda Zodiac 1500,
    Taylor FAS-DPD K-2006 Test Kit.

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Small Drip on Multi Port

    Yes, different from the o-ring on the filter, though the same basic idea behind it.

    The multi-port opens up after you remove a couple of bolts and disconnect the handle. There are several parts that you need to keep straight so you can put them back when reassembling, but otherwise it isn't all that difficult. If you feel up to it, you could take it apart and check the o-ring and the surfaces it presses against and make sure there aren't any nicks or cuts and everything is lightly lubricated with a silicone based plumbers lubricant. Depending on what you find, you may need to replace an o-ring or two.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5
    brmommy's Avatar
    Join Date
    Jul 2013
    Location
    Southeast Ohio
    Posts
    74

    Re: Small Drip on Multi Port

    It seemed to resolve itself before I did anything.
    27' Round X 54" Aqua Leader Sentinelle AGP, Vinyl J hook liner. 18,500 gal.
    Waterway 19" oval sand filter, US Motors EZBN25 1.0 hp 1.5 SPL Pump, BBB (Empty Aqua Smarte System connected, may use during vacation), Barracuda Zodiac 1500,
    Taylor FAS-DPD K-2006 Test Kit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •