Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Jandy Stealth Pump running dry?

  1. Back To Top    #1
    HouTX's Avatar
    Join Date
    Apr 2015
    Location
    Katy, TX
    Posts
    49

    Jandy Stealth Pump running dry?

    ( I am a newbie first time pool owner ).I have 2 pumps, one for the pool and one for the waterfall. I cleaned the pump baskets last week and noticed that the pool pump was running whisper quiet So I looked at it this morning and seems to be running dry. There is no splashing water visible through the lid, just some fine particles floating. So I turned on the other pump (waterfall) and I can see and hear the gush of splashing water as it is on, but not on the pool pump.

    My hot tub with spill over is working when the filter pump turns on, so my question is would the spill over work if the pool pump were running dry ?
    30k Gal, IG, PebbleTec, Jandy: CL460 Cartridge Filter, SHPM2.0 Pump (Filter+Spa), SHPM1.5 (Waterfall), spill-over SPA, PLC1400 SWG, LXi400 Heater. Polaris Caretaker Infloor Cleaning system, Jandy PDA-PS-8 remote, Taylor K-2006 Test kit

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Jandy Stealth Pump running dry?

    No, the pool pump is normally the pump that powers the spillover.

    Running dry is called losing prime. If that happens you want to re-prime the pump. That means turn the pump off, fill the pump strainer basket with water, turn the pump on again, and watch to see if it gets going correctly or runs dry again.

    You don't want to run the pump dry, as this can damage the pump.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    HouTX's Avatar
    Join Date
    Apr 2015
    Location
    Katy, TX
    Posts
    49

    Re: Jandy Stealth Pump running dry?

    Yes, I did learn about priming the pump on this forum and was able to get it primed after cleaning. So, if the spillover is working than the pump is primed and not running dry ? Or can it lose prime but still work ?
    30k Gal, IG, PebbleTec, Jandy: CL460 Cartridge Filter, SHPM2.0 Pump (Filter+Spa), SHPM1.5 (Waterfall), spill-over SPA, PLC1400 SWG, LXi400 Heater. Polaris Caretaker Infloor Cleaning system, Jandy PDA-PS-8 remote, Taylor K-2006 Test kit

  4. Back To Top    #4
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Jandy Stealth Pump running dry?

    I'm confused here. If the pump is pumping water then it is primed and running fine. Why do you think it is dry?

    The process of priming a pump is done at start up where the basket and pipe are filled with water so that the pump can start pumping water. Once this is done it generally stays primed for a long time unless something happens.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  5. Back To Top    #5
    HouTX's Avatar
    Join Date
    Apr 2015
    Location
    Katy, TX
    Posts
    49

    Re: Jandy Stealth Pump running dry?

    I have two identical pumps (except for amps), sitting next to each other. When I turn the waterfall pump on I can clearly see and hear the water splashing around from the lid. When I turn the pool pump on I see/ hear no water splashing (unless it is full and totally clear up to the lid). I do see small matter floating but I can't tell if it is full of water or air!
    30k Gal, IG, PebbleTec, Jandy: CL460 Cartridge Filter, SHPM2.0 Pump (Filter+Spa), SHPM1.5 (Waterfall), spill-over SPA, PLC1400 SWG, LXi400 Heater. Polaris Caretaker Infloor Cleaning system, Jandy PDA-PS-8 remote, Taylor K-2006 Test kit

  6. Back To Top    #6
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    23,999

    Re: Jandy Stealth Pump running dry?

    Quote Originally Posted by HouTX View Post
    I have two identical pumps (except for amps), sitting next to each other. When I turn the waterfall pump on I can clearly see and hear the water splashing around from the lid. When I turn the pool pump on I see/ hear no water splashing (unless it is full and totally clear up to the lid). I do see small matter floating but I can't tell if it is full of water or air!
    Oh, I see. I'm familiar with your other thread. Yes, it is entirely possible for the basket to be completely full of water and look like there is nothing in there and have lots of water going through it. The little bit of debris passing through is a good sign that water is moving through. But a better sign is that there is water coming out of the end of the pipe.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •