Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Blue RTV For Spider Gasket?

  1. Back To Top    #1

    Join Date
    Sep 2014
    Location
    Honduras
    Posts
    12

    Blue RTV For Spider Gasket?

    Blue RTV pic: https://onedrive.live.com/redir?resi...nt=photo%2cjpg


    Hi everyone. I replaced my spider gasket and used Blue RTV Silicone to bed the new spider gasket. After about a week the filter stopped filtering again. After a couple more weeks of vacuuming to waste, I pulled the valve apart and it looks like the spider gasket is ok. I heard that sometimes the gasket will roll over underneath the top part of the valve so I checked for that and sure enough it was loose. The gasket ended up coming out of the channels like I'd never used anything at all to make it stick. No residue left in the channels, at all.

    I'm thinking maybe blue RTV is not the right stuff? Or maybe I didn't use enough?

    Here's a link for a few pics of the valve and spider gasket, in case anyone can see if maybe it's a different problem. There's a video that shows the handle spring in action, in case you can tell if that would be the problem:

    https://onedrive.live.com/redir?resi...t=folder%2cmp4


    Drew
    Honduras

  2. Back To Top    #2

    Join Date
    Sep 2014
    Location
    Honduras
    Posts
    12

    Re: Blue RTV For Spider Gasket?

    Here's a pic of the valve without the spider gasket installed - looks like there's a bit of blue rtv residue. Can anyone see any problems with the channels themselves?

    https://onedrive.live.com/redir?resi...nt=photo%2cjpg

    Drew

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •