Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Haywood filter leaking from gap between base & lid of cartridge case

  1. Back To Top    #1

    Join Date
    Apr 2015
    Location
    Safety Harbor, FL
    Posts
    1

    Haywood filter leaking from gap between base & lid of cartridge case

    I have a Haward c1200 filter which I had someone install for me a couple of years ago. It's worked fine until just the last week or so. All of the sudden one day water came blasting out between the base and lid of the filter casing. I noticed there was about a 1/4 inch gap between the base and the lid and figured it hadn't been put on tightly the last time it was cleaned. I opened it up, made sure the cartridge was in straight, and made sure the lid was on straight and tight. But there is still about a 1/4 inch gap. It's close enough that I can run the pump for a while, but eventually when the pressure gets high enough, the part of the o-ring gets forced through the gap and water blasts out enough.

    I tried a second filter cartridge and the gap is about the same. Seems like it should be a fairly simple issue to fix, but I can't figure out how to get the lid down further to eliminate the gap. Any ideas?

    Thanks,
    Paul

  2. Back To Top    #2

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    943

    Re: Haywood filter leaking from gap between base & lid of cartridge case

    If you still have manual you can see a breakdown of parts. You might want to check the tie rod, make sure it is threaded in properly, and all other parts are in correct order. If you don't have manual you can download from hayward.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •