Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Freshwater III ozonator issues

  1. Back To Top    #1

    Freshwater III ozonator issues

    I have a 2001 Tiger River Sumatran spa. Before I drain and refill, I like to run vinegar through the tubing that connects to the bottom of the ozonator. Today when I tried this, and turned on the jets, the vinegar was not getting sucked through the tubing at all. I unthreaded the nut holding the tube to the injector and cleaned out the the inside of the injector with a swab and vinegar. Reconnected and tried running the vinegar through the tubing under the ozonator and again, the tubing was not drawing the vinegar. My question is, could it possibly be the ozone check valve? I am getting bubbles coming out bottom of the spa, but I guess no ozone. I have had the ozonator for 8 years and am wondering if there is a sure fire way to determine if the ozonator is bad before shelling out 275.00. Any help would be appreciated

  2. Back To Top    #2
    Mod Squad
    Join Date
    Aug 2012
    DFW, TX

    Re: Freshwater III ozonator issues

    Sorry, I've got no help on ozonators. But, here's a
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts