Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Issues when opening?

  1. Back To Top    #1

    Join Date
    Jul 2014
    Location
    Ponca City, OK
    Posts
    57

    Issues when opening?

    I live in Oklahoma, the weather changes quicker than you can blink. We had a relatively mild winter, now we have highs that are hitting in the 80's and dropping back down into the 40's the past week or so. The pool was drained down to about 6" below the skimmer at closing. The cover is still on. I did a quick clean of the filter prior to closing. My question, what issues do you all think I am looking at when I open? I am thinking about doing it this weekend or next. Thoughts? Have a 12k IG pool with a Pentair 36 DE filter.

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Issues when opening?

    No way to guess what issues you might have ... the longer you wait, the more likely you are to have problems.

    What is your water temperature? We recommend opening when the water is still in the 50s to lower the likelihood of algae.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Join Date
    Jul 2014
    Location
    Ponca City, OK
    Posts
    57

    Re: Issues when opening?

    Have decided to go ahead and
    open my pool. Does anyone know of a tool that can be used to help pull the cover off. Really had difficulty putting the cover on when we closed. Cover kept falling in the water with 4 of us trying to get it covered,
    I will admit, it was our first ever closing.

  4. Back To Top    #4
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Issues when opening?

    We have no idea what kind of cover you have. Post a picture.

    Please add your pool details to your signature as described HERE as it will help us help you.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  5. Back To Top    #5

    Join Date
    Jul 2014
    Location
    Ponca City, OK
    Posts
    57

    Re: Issues when opening?

    Quote Originally Posted by jblizzle View Post
    We have no idea what kind of cover you have. Post a picture.

    Please add your pool details to your signature as described HERE as it will help us help you.
    Sorry, I did check my signature in my profile and it is there. I am not sure why it is not being added to my posts. Thanks for the reminder. Hope it shows now. Please let me know if it does not.
    Pool Data:

    12K gal, IG Vinyl, 1.5 HP Whisperflo Pump, 36 Sq Ft Pentair NFS Plus 36 DE Fiter. Pool Built 3-7-2007

  6. Back To Top    #6

    Join Date
    Jul 2014
    Location
    Ponca City, OK
    Posts
    57

    Re: Issues when opening?

    Quote Originally Posted by jblizzle View Post
    We have no idea what kind of cover you have. Post a picture.

    Please add your pool details to your signature as described HERE as it will help us help you.
    Here you go


    Pool Cover.jpg
    Pool Data:

    12K gal, IG Vinyl, 1.5 HP Whisperflo Pump, 36 Sq Ft Pentair NFS Plus 36 DE Fiter. Pool Built 3-7-2007

  7. Back To Top    #7
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Issues when opening?

    I think there are tools you can buy to remove and install these. Or there are alternative methods that i think I saw discussed on the forum previously. Have you tried searching the forum?
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  8. Back To Top    #8
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Issues when opening?

    The cover looks to be in good condition and fully intact, chances are the water is in good shape. You might have algae, or might not, but almost no chance of any significant number of leaves or other solid debris (which is what makes opening difficult).
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •