Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Pump not sucking water

  1. Back To Top    #1

    Pump not sucking water

    Opening up the pool for the first time since being built last year. The company closed the pool since they installed a safety cover. I took off all drain plugs and reattached the gauge on the filter as well as the drain cap. I filled the pump with water until the intake lines were filled. I set the filter to "filter" and turned on the pump. The pump is on but does not continue to suck the water from the pool. Does it need time to fill the filter back up to regain suction? I even tried running water in the pump while it was running to see if that would get the suction back.

    Thanks for any help. Oh and the bright side is the water is crystal clear!

  2. Back To Top    #2

    Join Date
    May 2013
    Long Island NY

    Re: Pump not sucking water

    Your rubber seal on the lid to the pump basket is good right? Not sucking air. It may just take a little while to fill the lines, and filter .
    Mine takes about 2 min. Also check air screw on filter, thumb tight.

    Sometimes the initial priming of the pump requires that lid on the pump to be closed after you filled it up with water from the hose. Mines kind of fineke like that, but once the pipes have water and no air in them then it's no problem to open the pump basket door. Hope this helps
    19,000 gal - Vinyl IG - Sand filter -1.5hp. - Taylor k 2006 - Loop Loc cover

  3. Back To Top    #3
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Tucson, AZ

    Re: Pump not sucking water

    Are the correct valves open?
    Did you lube up the pump lid o-ring?

    You have to have the pump lid on when trying to run the pump.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  4. Back To Top    #4

    Re: Pump not sucking water

    Finally got it going. I guess needed more time to fill up the filter and get some water pressure. I was just nervous I was going to burn out the pump.

    Thanks guys for the tips.

  5. Back To Top    #5

    Join Date
    May 2014
    Virginia Beach

    Re: Pump not sucking water

    Fellow neophyte here. I found that I had to let the hose fill the pump basket for a LONG time to ensure that the lines (between the pump and the pool) were full of water. Not at all sure if that's legitimate or not, but it worked. I watched a YouTube vid and the guy just let his pump suck air forever before it finally primed. That seemed pretty stupid to me.
    8-10,000 Gallon In Ground Pleasure Pond. Probably 15 (?) years old.
    Recently new Groovy Blue Vinyl liner. Newer Hayward DE filter and Aqua-Rite SWG system.
    Eight Passive Solar Heating Panels. 1HP single speed motor.
    Virginia Beach, VA.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts