Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Salt too High

  1. Back To Top    #1

    Join Date
    Apr 2015
    Burlington, NC

    Salt too High

    Hi -- I added 160lbs of salt to my pool and suddenly the red high salt light appears. Before this it said check cell and no salt reading. I did that (cleaned cell) and then thought I should add salt since it was the first time i added it since June of last year. How do I get this corrected?

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Salt too High

    Welcome to TFP!

    You should turn off the SWG for 24 hours after adding salt, leave the pump running for those 24 hours, and then turn the SWG back on and let it measure the salt level to see what it is.

    Salt levels in the first 24 hours will fluctuate wildly as the salt mixes into the pool water.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    TFP Guide
    Kiss4aFrog's Avatar
    Join Date
    May 2013
    Hudson, WI

    Re: Salt too High

    Welcome to the forum Elvis

    Please add your pools info into your signature and outlined here - - >

    Need the information that would be in your signature to answer the question.
    '70s IG Vinyl 32K gal, Lazy L, Hayward SuperPump 1.5hp 120V, S240 Sand Filter W/DE
    Solar Blanket, Well Water, Borax Added, TF-100 tester. May 20 - opened for summer
    1979, 275gal Conway Emerald Spa P-100-2, ES-2 Spa Pack, bromine floater, indoor
    TF-100, Best test kit -
    Please help keep the lights on so we can be here for others, become a TFP Supporter!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts