Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Algae in my pool

  1. Back To Top    #1

    Join Date
    Jul 2013
    Location
    Royse City, TX
    Posts
    32

    Algae in my pool

    Hello,

    This was my first winter to have an above ground pool and with very little attention thru the winter I have a good case of algae.

    I have the Tf100 test kit.

    My ph is off the chart. Do I continue to add muratic acid until I get to the desired level before beginning to SLAM?

    Help is needed in North Texas.

    Thank you,
    Esther Williams Classic, 30' Round AGP, Hayward Pro Series Sand Filter, Pentair 340104 Dynamo 115V Single Speed

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: Algae in my pool

    Short answer: yes, fix pH first.

    What are the rest of your readings like? If CYA or CH has built up to where you might want to replace some water, do that first. Otherwise, fix the pH and jugs away.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    Join Date
    Jul 2013
    Location
    Royse City, TX
    Posts
    32

    Re: Algae in my pool

    We are moving in the right direction.... seeing some improvements!!!
    Esther Williams Classic, 30' Round AGP, Hayward Pro Series Sand Filter, Pentair 340104 Dynamo 115V Single Speed

  4. Back To Top    #4
    Mod Squad tim5055's Avatar
    Join Date
    May 2014
    Location
    Columbia, SC
    Posts
    8,494

    Re: Algae in my pool

    Quote Originally Posted by TaraMM View Post
    We are moving in the right direction.... seeing some improvements!!!
    great!! Get the pH in line then SLAM away.
    TFP Moderator 39 X 18 23,000(ish) freeform gunite; built 2007ish; Pentair Triton II TR100 600lb Sand filter; 2 HP Pentair pump with 2.2 HP AO Smith single speed motor; 2 skimmers, 1 main drain, 4 returns w/waterfall, Stenner 45MHP2 3GPD running@ 60% - 15 gal Tank; heated by the sun CYA 200+ when I started - 50 now. Dolphin Supreme M5 Pool Cleaner. Hot Springs SX Spa, 285 gallon

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •